PDA

View Full Version : DX4 PrintHead required



Davainis
10-18-2011, 05:25 AM
hey guys ,

agian problems with my mutoh rockhopper 2.

When i sorted the problem with blurry images ( it was the headcables )

I came across another problem with the printhead.

No light colors :/ They were fine last time, now both Light colors are gone :(

the pump is pumping the ink , but no color at the nozzle check is appearing .

Any ideas? or the head is dead ?



Anyone got used DX4 head to sell :/ ???


Thank you for the answers

premiercolour
10-20-2011, 01:56 AM
you don't want to buy the used heads because if they are usable; why people sell them? We sell brand new print heads for much less. www.fieldcenterusa.com

artbot
10-20-2011, 02:14 AM
when you say "light colors" you mean lm lc, right? if that entire head just quite printing than i doubt you have a blown head. do a search on this board for "data swap" you will have to transpose there's a diagram about how to do one on a mimaki. you will have to transpose the diagram. or even call someone that's familiar with your model and they can pace you through it. ...the next thing to do in diagnosing is the data swap.

MikePro
10-20-2011, 04:57 AM
labas! Aš esu lietuvis!

i've noticed your previous posts about your printer issues. Was it really head cables that fixed the problem before? How do you know it is the print head now?
artbot is correct, a data-swap should be attempted at this point. power-down your machine and swap the cables at the head with the cables of another head, power-up, and test to see if the problem followed.
I wouldn't be surprised if it is something as simple as a cracked ribbon cable or at least a mis-seated connection.

also,
posting pictures of your nozzle checks/test prints, the printer carriage, and the bottom of the printheads (if possible) can help us help you find the source of your issue.

Davainis
10-20-2011, 05:28 PM
yeah lm lc.

I tried the to swap the cables still the same !

Then i installed an old printhead , but it prints 5% out of 100%.

So i think the head is bad.

I will post the pictures tomorrow.

Thx for the help...