Welcome to Flexi FAMILY 8.6v2 and PhotoPRINT 6.1v2

FlexiSIGN is the world's most advanced signmaking software and we have added many new features
based on your feedback.

What is on this DVD?
Most of the items on the DVD install with Flexi and PhotoPRINT or are accessible through the installer.
The following items are loose on the DVD.

\Acrobat: Adobe Acrobat 9 full English installation
\Goodies - Samples from vendors that make SAi Certified Accessories
\ICCProfile - Color management profiles for hundreds of printer models.

\UtiNColorspan - Utility for Colorspan printer and drivers for Videonet network interface

\Util Cut Server - Application for the Mutoh cutters to send bar code cut files

\UtiNEncad\Go - Application to send native (RTL) file directly to device from DOS

\UtiINEncad\EFPUv30 - Installer for application to send native (RTL) files from Windows. Includes an RTL
viewer

\Uti\Eye-One driver - USB driver for Eye One colorimeter

\UtiNGetKeyID: Detects all SAi keys and reports back the user ID.

\Uti\Hasp\HASP_SRM_Runtime_cmd_line

\UtiI\HP DesignJet 9000s USB driver - USB for the HP9000s printer

\Uti\Mimaki Firewire - Drivers for Mimaki Firewire port

\Uti\Monitor - Adds Hot Folder port to shared printers

\Uti\Seiko IP-5600 IP-6610 IP-6910 USB driver: Latest USB driver for Seiko IP-5600,IP-6610, and
IP-6910

\Uti\Sentinel - Rainbow key driver and utilities

\UtiINUSB-PIA - Windows driver for Macintosh USB-PIA cable

\Uti\versacamm_ver.300 - Roland VersaCAMM SP-300 USB driver

See us online at: http://www.flexi85.com
Send us suggestions or ideas to: Suggestions@SAintl.biz

Operating Systems Supported

Windows XP Home

Windows XP Professional

Windows XP Professional x64 Edition using AMD64 or Intel EM64T
Windows 2003 Server

Windows Vista Home Basic 32-bit (x86) or 64-bit (x64) processor
Windows Vista Home Premium 32-bit (x86) or 64-bit (x64) processor
Windows Vista Business 32-bit (x86) or 64-bit (x64) processor
Windows Vista Ultimate 32-bit (x86) or 64-bit (x64) processor

Flexi 8.6v2 and PhotoPRINT 6.1v2
Build 1465
23 February, 2009

New Features

. Support multiple contour cuts in order to do a contour cut and a perforation cut on most cutters.
Create the contour cut as usual, then create a second contour cut around the first by selecting
Effects>Contour Cut again. For the perf cut, you can choose a separate color in order to assign
cutting parameters in the RIP and Print dialog, or choose a dashed line style in order to have
Flexi automatically leave small segments uncut.



. Two additional colors now appear in the default color swatch: “CutContour” and “PerfCutContour”.
EPS export will retain the colorname of any contour cut paths with “PerfCutContour” color. Other
contour cut colors will be merged into “CutContour” on export.

. Added custom line styles in the style menu of Contour Cut and in the style menu of the stroke tab
of Fill/Stroke Editor. Choose "Edit..." from the style list in order to create new line styles or to edit
or delete an existing custom style. Default styles cannot be modified.

. Cut/Plot and RIP and Print now show icons rather than text in the tabs.

. RIP and Print>Advanced>Contour Cut has been moved to a separate tab (RIP and Print>Contour
Cut). You can now see all color layers and assign separate cutting parameters for each.

. Added support for Roland VersaWorks 3. The "Send to VersaWorks" dialog now allows the
choice of any of the setups. File successfully sent message is now suppressed

. EPS export and Send to VersaWorks now uses the same color space as PDF for more accurate
CMYK reproductions.

. Added support for direct Redsail USB port instead of using COM port emulation.

. Updated Seiko USB library in util folder

° Updated HP-Colorspan VideoNet Drivers in util folder

) Reconverted ICCs for improved smoothing

. Improved default Ink Split values

. Added new Ink Split Smoothing method

. Added Import Ink Split in order to import ink split data from another profile.

. Reset Ink Split now only resets the current channel

. Added Use Neutral Linearization for use with 3rd party profiles that were already linearized. The

preview of Neutral Linearization is not representative.

SO parameters are now stored inside ICC profile for easier exchange of profiles
Updated SHK driver to 7.5.0 from 7.4.0.

Added Underbase and Finisher to FlexiPRINT&CUT and PhotoPRINT DX

Jobs for hybrid devices now allow you to choose another cutter in job properties.

Bug Fixes

DCS files now have linearization and ink split properly applied.

Improved color accuracy when using 3rd party ICC profiles. The output is no longer too dark.
Fixed a RIP error that might occur when printing 3rd party hexachrome targets.

Spot colors in PDF files are now recognized

Object color control now displays and uses correct output values after using color adjustments.
Adobe lllustrator files with large numbers of spot colors no longer cause a crash generating the
preview.

Transparency is now properly interpreted when adding a job directly into production.

Fixed contour cut shifting issue with uneven resolutions.

Fixed a contour cut offset of 0.1in on Mimaki cutters.

Improved island fill to remove gaps in output.

Color Span 54XX no longer shows the command window when running

Fixed an issue with translated cutter driver options causing incorrect cutter output.
readprinter.exe and writeprinter.exe have been removed from the installation disc. These files
erroneously were detected as a virus by some checkers.

DXF export no longer distorts the output when using save as arcs option.

Network key check now works on 64 bit Vista

Bitmaps can now be pasted into other applications

Multiple copies, tiles and pages now respect the rotation after break apart and unnest.
Workflow presets now respect default offsets.

Fixed an issue with nesting of tiles/jobs with labels and marks and offset changes when
reopening Job Properties

. EPS files with more than 64 characters in flename can now be opened



Fixed an issue with resizing dimension lines
Removed limit of COM9. You can now configure up to COM256.
Fixed an issue that sometimes a black hairline was printed on the edges of a file

New Printer Drivers

Hewlett-Packard: Scitex FB950

Epson : Stylus Pro 7900, Stylus Pro 9900

Mutoh: VJ-1618, VJ-1618 Asia

Pentum:TW-3304HA, TW-3306HA, TW-3308HA, TW-3304GA, TW-3306GA, TW-3308GA,
TW-3304HB, TW-3306HB, TW-3308HB, TW-304GB, TW-3306GB, TW-3308GB, TW-3308HC,
TW-3306HC, TW-3316B, TW-3316B+, TW-3304TA, TW-3306TA, TW-3304LE, TW-3306LE,
TW-3308LE

Roland: Soljet Pro Il XC-540 Plus Pass, VersaUV LEC-300

Seiko Instruments: LP-1020, LP-1020L, LP-1020-MF, LP-1020L-MF

New Cutter Drivers

LiYu Cut: SC Series, SE Series, ME Series, TE Series, MC Series, MF Series, HF Series
Mutoh: SC-PRO 1650, SC-PRO 1400

RedSail Tech: RS1360D, RS450D, RS720D, RS800D, RS1120D, RS1360D

USCutter: Creation PCUT CTN630, Creation PCUT CTN900, Creation PCUT CTN1200,
Laserpoint 24, Laserpoint 36, Laserpoint 48, Copam CP-2500, Copam CP-3000, Copam
CP-3500, Copam CP-4000, Copam CP-4500, MH-365, MH-721, MH-871, MH-1351

Removed Drivers

Mutoh: VJ-1618 Europe 720 (ValueJet), VJ-1618 US 360 (Valuedet), SC-PRO

SidRacing : SID XC-250 4C, SID XC-250 6C, SID XC-320 4C, SID XCS-320 4C, SID XC-320 6C,
SID XE-180 6C, SID XE-180 4C, SID XE-210 4C, SID XE-320 6C, SID XES-320 6C, SID XQ-180
6C, SID XH-180 6C, SID XH-250 6C, SID US-320/8 4C, SID US-320/6 4C, SID US-320/6 6C

Limitations / Known Problems

Printing CMYKRGB targets from 3rd party profiles may overink. Use the SAi Color Profiler for
optimal results with multi channel profiles.

ICC profiles with ink split created in v2 will not give good results when used in previous

versions. V2 profiles store extra parameters for smoothing that previous versions will not be able
to interpret.

When you first plug a GX cutter into the PC, it will prompt you with “Found New Hardware...”. If
you skip that, you can still cut by using the USB_Printer_0 port in PhotoPRINT, but that OS port
does not support poll size. In order for poll size to work, you must install the driver from the GX
CD that comes with the cutter, then select the Roland USB0002 port.

When the 9000s is attached to the PC, it may prompt you with "Found New Hardware". The
necessary Windows USB driver files for this printer can be found on the installation CD in the
UtiINHP DesignJet 9000s USB driver folder

Windows Vista - SCSI does not currently work on Windows Vista. You may find that many device
drivers are not yet supported in Vista, such as devices requiring their own USB drivers.

A networked Production Manager is not possible with softkey.

When creating a profile using light inks and some print mode/media combinations you may find
that too much ink is laid down. To correct this lower the total ink setting on the last step on profile
generation. This happens most often on printers with more than 6 inks.

The gray balance step in the Color Profiler may produce undesirable results under some
ink/media combinations. This feature is best used when printing grayscale images.

Profiling for the RGB mode of the HP Z-series printers will not work correctly although CMYKRGB
works correctly.

Fotoba and Fotoba Horizontal Marks don’t print on the HP Z3100.

Dual Roll does not properly support crop marks when set to "one set for all".



When you first plug a GX cutter into the PC, it will prompt you with “Found New Hardware...”. If
you skip that, you can still cut by using the USB_Printer_0 port in Production Manager, but that
OS port does not support poll size. In order for poll size to work, you must install the driver from
the GX CD that comes with the cutter, then select the Roland USB0002 port.

Roland GX cutters will not polls size or read contour cut registration marks on Windows Vista
64-bit systems. It will function correctly on Windows Vista 32-bit systems and other Windows
operating systems. At the moment, Roland has not developed a Vista 64-bit USB driver for the
GX cutters.

When the 9000s is attached to the PC, it may prompt you with "Found New Hardware". The
necessary Windows USB driver files for this printer can be found on the installation DVD in the
UtiNHP DesignJet 9000s USB driver folder.

Some transparent bitmaps do not preview correctly in the General tab of RIP and Print. All other
tabs and output is not effected.

Some default media names for the HP Z-series printers contain a "/". This causes a failure to
create new ICC error messages for these media types. In order to successfully generate an ICC,
you will need to rename the media in the Profile Setup tab of Color Profiler.

There is an issue importing HPGL/2 files with ".HP2" extension. Rename the file to ".PLT" to
properly import into Flexi.

Output may be slow when using a TCP/IP to LPT adapter using an SEH print server. To eliminate
pausing, turn on "Fast Mode" from Printer Server>Homepage>configuration>Print Port.
Windows 2000 requires 128-bit encryption be installed, or you will not be able to install the
software. If you have only 56-bit encryption, download the High Encryption Pack from Microsoft at
http://www.microsoft.com/windows2000/downloads/recommended/encryption/en.mspx or on the
CD at \UtiNWindows 2000 High Encryption Pack \ENCPACK.EXE

Canon imagePROGRAF printers do not allow new media to be added to the list. If you are
creating a new profile, choose an existing media and enter your media in the "Media Display
Name" field. This is required because the printer needs to know the base media in order to setup
printing parameters such as number of passes.

Object Color Control will not work for spot color unless "Use color mapping" in unchecked.

Revision History

FlexiFAMILY 8.6v1 SP1

Build 1437

November 20, 2008

English, Portuguese, French, German, ltalian, Spanish, Dutch, Russian, Chinese Simplified, Chinese

Traditional, Japanese, Korean release

Changes:

Added support for new languages: Dutch, Russian, Chinese Simplified, Chinese Traditional,
Japanese, and Korean.

Improved translation for Portuguese and Spanish.

SpotOn has been renamed to “SO Diffusion”.

Fixed an issue where application may show Build Number 0001 after installation, and will not
install any localization files or patches.

Profiler Converter no longer introduces inaccuracies into the ICC Profile when converting a profile
with light inks.

Improved layout of multiple copies of contour cut jobs so that the print and cut jobs have the
same number of columns and rows.

Fixed an error that could occur when nesting jobs with different ICC profiles.

Changing the output resolution of one file in a nest will now change all files in the nest to use the
new resolution.

Added Invert Bitmap filter.

Object Color Control and Spot Color Mapping with SO Diffusion no longer display light ink values.
The light ink is automatically calculated based on the ink split curve.



. Fixed an issue with the legacy profile converter that old profiles containing ink split would be
washed out. If you experience washed out prints, reconvert the legacy profile with SP1.

Driver Changes

. RedSail Tech: added advance after plot support.

SID Racing: Drivers merged into SID Signs

Mutoh Viper: Added additional driver options.

Mutoh Cutters: Pounce selection is now properly set.

ColorPainter H-104S (SI1IP-7900), ColorPainter H-74S (SIlIP-7700): Light inks are no longer
swapped.

New Printer Drivers
. Canon: imagePROGRAF iPF8110, imagePROGRAF iPF8010S, imagePROGRAF iPF9110,
imagePROGRAF iPF9010S

) DGI: XP-1604, XP-1804D

. Mimaki: CJV30-60, CJV30-100, CJV30-130, CJV30-160, TPC-600

) Roland: VersaArt RS-540, VersaArt RS-540

) SID Signs: SID1000-108, SID1000-120, SID1000-30, SID1000-60, SID1000-90, SID2000-108,
SID2000-108 USB, SID2000-120, SID2000-120 USB, SID2000-60, SID2000-60 USB,
S1D2000-90, SID2000-90 USB

o Supermentos: SM-Konica 4C, SM-Konica 6C, SM-Seiko 4C, SM-Seiko 6C, SM-Xaar 4C,
SM-Xaar 6C

. Vinyl Express: R24, R39

New SO Diffusion ICCs

Canon imagePROGRAF iPF8000S 9000S
Epson Stylus Pro 3800

Epson Stylus Pro 7800 9800
Epson Stylus Pro 7880 9880
Epson Stylus Pro 11880

Epson Stylus Pro GS6000
Gerber Solara ION

HP DesignJet 5100

Mimaki JF1610

Mimaki JV5

Mimaki JV33

Mutoh Blizzard

Mutoh Rockhopper FalconOut Il
Mutoh VJ

Roland VersaArt RS-540
Roland VersaCAMM

Roland VersaCAMM VP

FlexiFAMILY 8.6v1

Build 1428

October 9, 2008

English, Portuguese, French, German, ltalian, Spanish release

New Features

. SpotON diffusion added. This diffusion is the default for all newly created profiles. It virtually
eliminates banding and produces vibrant, accurate output which far exceeds any other method.
To take full advantage of SpotON, you need to create a new ICC profile. SpotON is able to



Fixes

produce perfectly smooth gradients by utilizing 16bit linearization. When using SpotON, object
color control settings will not be accurate when using device space. RIP speed of SpotOn is
about 4 times faster than Error Diffusion (a bit slower than FMXpress) but with greatly improved
output.

Object color control and spot color mapping with SpotON diffusion does not allow light ink values
to be set. The light ink is automatically calculated based on the ink split curve.

3 level 2 bit dithering support for HP DesignJet 5100 using SpotON diffusion.

Send to VersaWorks option added to the file menu and to standard toolbar to automatically add
the current design to the VersaWorks queue. This command will be hidden if VersaWorks is not
installed. Use \Program\Add RVW.reg to manually update the registry key if needed.
Help>Check for Updates is a new method to check for software updates. Newly created updates
will show on the web page. Simply click to download and install them. Check periodically for any
updates.

Improved smoothing for inksplit with option for either Linear or Cubic curves. You can also add
additonal points on the curve by double clicking. Dark and light inks are no longer limited (0-100%
range)

Added preview of XYZ measurement curve in linearization dialog

Fixed a crash that could occur when printing with a template.

ICC Profiles have been reconverted to produce more vibrant colors.

Improved error handling of X-Rite IO spectrophotometer.

Softproof button added to the standard toolbar

Support for restricted user

Fixed a crash when using Google Pinyin Input Method

Contour cutting no longer cuts unidirectionally

Join Points / Align Points are now based on which points are selected when tool is used.
Negative print now works for EPS files

Gerber Edge no longer prints inverted registration mark

Gerber Edge now installs ICC profiles and prints with correct default angled screen settings for
optimal results.

Underbase no longer prints solid under entire drawing

Acrobat updated to 9.x

Better alignment of contour cut copies

Network SHK key can be detected if you have up to 100 key servers running (previous limit was
10)

Fixes a crash in break apart that could occur when you turn on the preview when loading in
Preferences

Contour paths in masks can now be recognized by RIP and Print.

Clicking to start a new arc text will no longer freeze.

Demo version no longer can send RIP jobs to a remote PM of a non-demo version.
Contour cut marks are no longer mirrored with the job.

Contour cutting now more accurately handles the layout of multiple copies.

True Shape Nesting now works properly with groups.

Roland VersaCAMM can now detect crop marks on a hybrid job.

Mimaki: Sending a test print or cleaning will no longer give an error message.

Mimaki JF added white ink support

Preset converter no longer truncates the filename.

Job properties no longer defaults to basic mode.

ReadPrinter/WritePrinter applications removed from installer. These files were erroneously
detected as viruses by some systems.

New Printer Drivers

Canon: imagePROGRAF iPF6000S, imagePROGRAF iPF6200, imagePROGRAF iPF810,



imagePROGRAF iPF820

C-JET: C-JET 3300

DGI: PS-3204D

Digital Printer: DP Model 2

Epson: Stylus Pro GS6000

Foison: FS8160, FS8160T, FS8250

GongZheng: GongZheng GZC3204-SPT510G, GongZheng GZC3206-SPT510G, GongZheng
GZC3208-SPT510, GongZheng GZC-3212-SKW128, GongZheng GZC-3216-SKW128,
GongZheng GZC-DP-180, GongZheng GZC-DP-360, GongZheng GZC-DP-360HI, GongZheng
GZE1804S-SPT255, GongZheng GZE1806S-SPT255, GongZheng GZE2504S-SPT255,
GongZheng GZE2506S-SPT255, GongZheng GZE2508S-SPT255, GongZheng
GZK-3204S-SPT510, GongZheng GZK-3206S-SPT510, GongZheng GZR-3208-Nova256,
GongZheng GZY-DP-180, GongZheng GZY-DP-360

Grapo: Octopus Il KM8 720UV

Hi-Jet: XG4320

HongHua Aprint: 160, 160UV, 330, 3308B, 3308B+, 330SWA, 330SWB, 3312c+, 3360EC,
3360EC-SL, 3360EC-SM, 3360SWA, 3360SWB, 3360SWS, 33VBX, 33VCX-12, 33VCX-8,
6250LQ, 6250LQ-SM, 8160XA, 8160XB, 8320LQ, 8320UV, FINA160, FINA160A, FINA1612UV,
FINA250, FINA250A-12, FINA250A-8, FINA320, FINA320A-12, FINA320A-8, FINA320B,
FINA320S, UV1612S

MydJet: MyJet K256-14-4C, MyJet K256-14-6C, MyJet K256-42-4C, MyJet K256-42-6C, MyJet
K512-14-4C, MyJet K512-14-6C, MyJet K512-42-4C, MyJet K512-42-6C, MyJet Spectra-256,
MyJet Xaar-126-4C, MyJet Xaar-126-6C, MyJet Xaar-128+-4C, MyJet Xaar-128+-6C, MyJet
Xaar-128-4C, MyJet Xaar-128-6C, MyJet1804-UV, MyJet1804-UVW, MyJet3204-UV,
MyJet3204-UVW

Seiko Instruments: ColorPainter H-104S (SIIIP-7900), ColorPainter H-74S (SIlIP-7700)
Wit-Color Digital: Ultra Nova H7

Xerox: 8254E, 8264E

ZhongYin: Lotus ICC KM512 4C, Lotus ICC KM512 6C, Lotus ICC S256 4C, Lotus ICC S256 6C,
Lotus ICC XR126 4C, Lotus ICC XR126 6C, Lotus ICC XR200 4C, Lotus ICC XR200 6C, Lotus
ICC XR720 4C, Lotus ICC XR720 6C

Removed Printer Drivers

Epson: Stylus Photo PX-G5000, Stylus Photo R1800

MyJet: Diecai-Jet3308, Diecai-Jet3312, Diecai-Jet3312 6C, Diecai-Jet3316, E-Jet3308,
E-Jet3312, E-Jet3312 6C, E-Jet3316, MyJet1804-K512,MyJet1808-126-Hi, MyJet1808-128-Hi,
MyJet1808-K512, MyJet1812-126-Hi, MyJet1812-126-Hi 6C, MyJet1812-128-Hi,
MyJet1812-128-Hi 6C, MyJet1812-K512 6C, MyJet1816-126-Hi, MyJet1816-128-Hi,
MyJet1816-K512, MyJet2204-K512, MyJet2208-126-Hi, MyJet2208-128-Hi, MyJet2208-K512,
MyJet2212-126-Hi, MyJet2212-126-Hi 6C, MyJet2212-128-Hi, MyJet2212-128-Hi 6C,
MyJet2212-K512 6C, MyJet2216-126-Hi, MyJet2216-128-Hi, MyJet2216-K512, MyJet2504-K512,
MyJet2508-126-Hi, MyJet2508-128-Hi, MyJet2508-K512, MyJet2512-126-Hi, MyJet2512-126-Hi
6C, MyJet2512-128-Hi, MyJet2512-128-Hi 6C, MyJet2512-K512 6C, MyJet2516-126-Hi,
MyJet2516-128-Hi, MyJet2516-K512, MyJet3304-SP256, MyJet3304-SP256-Hi,
MyJet3306-SP256 6C, MyJet3308-126, MyJet3308-128, MyJet3312-126, MyJet3312-126 6C,
MyJet3312-128, MyJet3312-128 6C, MyJet3316-126, MyJet3316-128, Poli-Jet3308,
Poli-Jet3312, Poli-Jet3312 6C, Poli-Jet3316

New Cutter Drivers

Aristo: Aristomat 1310x10, Aristomat 1317x10, Aristomat 1617x10, Aristomat 1625x10, GL
2032-8, GL 2232-8, GL 3132-8, GL 3152-8, TL 1310-8, TL 1617-8, TL 1625-8

Foison: C30, S30, S30-USB

Mimaki: CG-60SL

ProCut: CR-1200, CR-1300, CR-1300F, CR-630, CR-730, CR-730F

Summa: D120R, D140R, D160R, D60R, D75R



o Vinyl Express: Q24, Q30, Q42, Q54, Q64

Removed Cutter Drivers

. Secabo: S120l1l, S12011I-USB, S30l1l, S30l11I-USB, S60lll, S60Il-USB
° Summa: D120 Pharos, D140 Pharos, D160 Pharos, D60 Pharos
New Engraver Drivers

. Aristo: Aristo-Router SL

. Tekcel: Controller

FlexiFAMILY 8.5v2SP1
Build 1398
August 14, 2008

Bug Fixes

. Fixed a bug where printing a large job to a TCP/IP printer may stop before print is complete.

. Added a utility to correct the white point of Monaco profiles. This can be found in UtiNICC white
point repair.

o Goodies and Acrobat folder were erroneously removed.

) Mutoh SC-PRO no longer sends incorrect driver option settings.

. Screen printing option no longer erroneously unlocks color profiler.

New ICC Profiles

Canon imagePROGRAF iPF5100 6100 8100 9100 (4 new profiles)
DesignJet 5500PS (1 new profile)

Epson Stylus Pro 11880 (4 new profiles)

HP DesignJet 8000s (4 new profiles)

Mutoh VJ-1608 (13 new profiles)

Mutoh VJ-1618 (21 new profiles)

Roland Hi-Fi JET FJ-40 FJ-50 (3 new profiles)
Roland VersaCAMM (1 new profile)

Roland VersaCAMM VP (20 new profiles)
Seiko TI-5600 (3 updated profiles)

Xerox 8254E (12 new profiles)

Xerox 8265 (12 new profiles)

New Printer Drivers

o AllWin: AllWin KONICA 256-14, AllWin KONICA 256-146C, AllWin KONICA 512-14, AllWin
KONICA 512-146C, AllWin KONICA 512-42, AllWin KONICA 512-426C, XAAR-128+-4C,
XAAR-128+-6C, XAAR-128-4C, XAAR-128-6C

. Canon: imagePROGRAF iPF6000S, imagePROGRAF iPF6200, imagePROGRAF iPF810,
imagePROGRAF iPF820

. Mutoh: Viper 100, VJ-1618 Europe 720 (Valuedet), VJ-1618 US 360 (Valuedet)

. ZhongYe: Z2Y-3400, ZY-5300, ZY-5300 6C

Removed Printer Drivers

° AllWin: AllWin XAAR-126-4C, AllWin XAAR-126-6C

Inwear: Inwear 4C, Inwear 6C

Seaband: SB-M2

Wit-Color Digital: Ultra 1000-380-6C Fly, Ultra 1000-380-8C Fly
ZhongYe: ZY-3300, ZY-3308

New Cutter Drivers
. Creation-PCut: CT-1200



. GCC: SignPal Jaguar I11-183

) Graphtec: CE5000-40-CRP, FC2250-120, FC2250-180, FC2250-60, FC8000-100, FC8000-130,
FC8000-160, FC8000-60, FC8000-75

) Mutoh: SC-PRO

. Xpert: renamed from Expert

Removed Cutter Drivers
. Seikitech: SK-1100ds, SK-1100H, SK-1350ds, SK-140, SK-280, SK-320, SK-360, SK-420,
SK-540, SK-720ds, SK-720H, SK-850ds, SK-850H

New Engraver Drivers

o Roland: EGX-350

FlexiFAMILY 8.5v2

Build 1355

May 20, 2008

Changes

. Preserve Pure Hue added to the Advanced dialog of Color Management. This function will
preserve pure color without stray pixels: Cyan, Magenta, Yellow, Black, Red, Green, Blue and
White.

o Ink Split allows the Light Ink curve to go to 100%

. You can now configure remote key detection to search a key on the network by specifying the IP

address. Modify C:\Program Files\SAI\SAi Production Suite\Program\AppComm.bin file to contain
the IP address of the system that has the hardware key.

. Demo mode has now been added back to the install manager.

. Hardware key now requires activation of the software within 15 days of installation. This can be
done from any computer with an internet connection by going to http://www.saintl.biz/reg and
typing the hardware key number and the first 4 digits of the password.

. ICC Profiles for the HP DesignJet 5000PS/5500PS/H35100 and HP Scitex FB910 have been
added to the installation DVD

) [-Cut Mark has been added to the Effects Menu to FlexiSIGN-PRO. This mark can be added on
any object with a contour cut path.

. Unidirectional cutting added to Advanced tab of Cut/Plot dialog. This is used for cutting material

with low levels of adhesive such as window tint film.

Bug Fixes

. Color Mapping now accepts colors with a \ in the name

. Fixed a problem with overinking at high resolution when using FMXpress
. Radial gradients now print correctly with FMXpress

. LAB images now print correctly with FMXpress

. Fixed a crash that could occur on adding a new job to the queue

New Printer Drivers

. Canon imagePROGRAF: iPF605, iPF720

) CrystaldJet: Cj-F3321B, Cj-F3312B+, Cj-F3308sky, Cj-F3308sky+, CJ-S3312B+,
CJ-F3308SPT510_35, CJ-F3308SPT255_35, CJ-S3306SPT510_35, CJ-S3306SPT255_35,
CJ-F3304SPT510_35, CJ-F3304SPT255_35, CJ-S9312SPT510_35

) Eastech: EZ-7400, EZ-7800, EZ-9400, EZ-9800, EZ-16000, EZ-3306, EZ-9000, EZ-1604W,
EZ-1618W, EZ-1608
Epson: Stylus Photo R1800, Stylus Photo PX-G5000

o Graphtec: JW310, JW330, JW331, JW500, JW501, JW700,

. HP: DesignJet 5100-42, DesignJet 5100-60, Scitex FB910, DesignJet H35100, DesignJet
H45100, DesignJet H35500, Designjet H45500



. Mutoh: VJ-1618 (Valuedet)

. ZhongYe: ZY-2600, ZY-2900, ZY-3300, ZY-7212 6C, ZY-7218 6C, ZY-7224, ZY-SK-3304,
ZY-SK-3306 6C, ZY-SK-3308, ZY-SK-3312, ZY-SK-5304, ZY-SK-5308, ZY-SK-5306 6C,
ZY-SK-5312 6C, ZY-SK255-3304, ZY-SK255-3306 6C, ZYUV-SK-3304, ZYUV-SK-3305 5C,
ZYUV-SK-3306 6C, ZYUV-SK-3307 7C, ZYUV-255SK-3304, ZYUV-255SK-3305 5C,
ZYUV-255SK-3306 6C, ZYUV-255SK-3307 7C

New Cutter Drivers
. Secabo: S30Il11, S60l1l, S120I1l, S30I1I-USB, S60111-USB, S120111-USB, C30lIl, C60lIl, C120lll
. SeikiTech: SK375T, SK720T, SK870T, SK1100T, SK1350T, SK720H, SK850H

Driver Changes
. Roland XC-540: plus pass support has been added
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Changes

. You can now connect to any Production Manager across a TCP/IP network with a single softkey.

. Spot colors of one job within nest are no longer applied to the other jobs

. Rotate Image to fit media now also works when scaling is changed in default job properties

. Color Mapping swatches now print the correct color

. Color Mapping swatches now get a unique name, so that several swatch tables can be in the
queue

. Grayscale images no longer print inverted

. You can now select "use embedded profiles" in the default job properties

. Adobe Plug-ins folder added to \Program Files\SAi\SAi Production Suite\Adobe Plug-ins to allow
installed plug-ins to be scanned automatically during program launch when Photoshop is not
installed.

. Optional configuration added for contour cut marks applied directly to design.

. Vision System Series 3 engravers can now connect through TCP/IP.

. Markup percentage in Job Estimation can now exceed 100%.

o Applying Templates with 100% scale now preserves the position of the original job.

3 Repeat job will now function correctly with contour cut jobs. Nested jobs will now print the correct
number of times.

. Performance improved when using horizontal or vertical dimensions or resizing.

. Resize will now maintain decimal precision defined in Edit>Preferences.

. Fixed RIP error when printing Custom Color Mapping swatches.

. Improved printing Duotone gradients.

. Font list in Text menu now continuously scrolls on Vista.

o Drawing colors no longer revert to defaults in Cut/Plot.

. Improvements applying island fills to certain object shapes.

. Production Manager preference added to use built in thumbnail preview.

o GCC AASII registration marks added to the contour cut dialog.

. Creation PCut registration marks added to the contour cut dialog.

Color Management Changes

. Gray Balance tab of Color Profiler hidden by default. Feature can be enabled by selecting the
checkbox on the Profile Setup tab.

Negative print option has been added to the Color Adjustment tab of Job Properties.
Improved Total Ink Limits when creating ICC profiles with large number of color channels.
Rendering Intent No Color Correction now respects the multi ink limit settings

Removed Spot Color rendering intent from the profile tab in DesignCentral.



Variations command now functions properly on Windows Vista.

Edit>Color Settings no longer shows incomplete ICC profiles.

Printing gradients from RIP and Print will now be consistent with Production
Manager/PhotoPRINT output.

CMYK Spot colors now print more consistently when printing through RIP and Print versus
Production Manager/PhotoPRINT.

Printing Linearization Only and No Color Correction now print correctly when using FMXPress.
Sending ink limit targets no longer causes CPSI error.

Eye One Isis now has option to enable UVcut filter.

HP Z series now has an option to measure immediatly after printing.

Add support for the following spectrophotometers: Gretag Spectrolino,Gretag Spectroscan,
Spectrocam, iO

Barbieri now reads the linearization step correctly

The different Osprey models now share a same folder for icc profiles, so that they can be shared.

Driver Changes

Several names for the Creation-PCut models have been changed per manufacturers request.
These include: Creation-PCut CR-1200 DMPL, CR-1500, CR-1500 DMPL, CR-630 DMPL,
CR-900 DMPL, CRN-1200, CRN-1500, CRN-630, CRN-900, CT-1200 DMPL, CT-1500, CT-1500
DMPL, CT-630 DMPL, CT-900 DMPL, CTN-1200, CTN-1500, CTN-630, CTN-900, MCR 270.
New model names can be found in the New Cutter Drivers section of the Readme.

Several printer driver names have been changed per manufacturers request. These include: DGI
ST-1806, Inwear Inwear 4C, Inwear Inwear 6C, Seaband SB-M2, Wit-Color Digital Ultra
1000-380-6C Fly, Wit-Color Digital Ultra 1000-380-8C Fly. New model names can be found in the
New Printer Drivers section of the Readme.

Fixed crash when adding the Eastech Corona T-1400 driver

New Cutter Drivers

Creation-PCut CR-1080, CR-1080F, CR-1200F, CR-630F, CR-900F, CS-1080, CS-1080F,
CS-1200, CS-1200F, CS-630, CS-630F, CS-900, CS-900F, CT-1080, CT-1080G, CT-1200G,
CT-630G, CT-900G, MC-270

GCC SignPal Jaguar IV-101, SignPal Jaguar 1V-132, SignPal Jaguar IV-183, SignPal Jaguar
IV-61, SignPal Jaguar IV-76

GoldCut GC-1101, GC-1351, GC-240, GC-330, GC-361, GC-721, GC-871

JinKa JK-1101, JK-1351, JK-240, JK-330, JK-361, JK-721, JK-871

Mimaki CG-60SR

Vinyl Express Q60

New Printer Drivers

AllWin AllWin XAAR-126-4C, AllWin XAAR-126-6C, AllWin XAAR-128+-4C, AllWin
XAAR-128+-6C, AllWin XAAR-128-4C, AllWin XAAR-128-6C

Asbru ASBRU Vidar 64

Canon imagePROGRAF iPF510, imagePROGRAF iPF710, imagePROGRAF iPF8000S,
imagePROGRAF iPF8100, imagePROGRAF iPF9000S, imagePROGRAF iPF9100

DGI STII-1806

Digital Printer DP Model 1

Epson PX-6250S, PX-6550, PX-7550, PX-7550S, PX-9550, PX-9550S, Stylus Pro 4450, Stylus
Pro 4880, Stylus Pro 7450, Stylus Pro 7880, Stylus Pro 9450, Stylus Pro 9880

Foison FS-3316, FY33VBX, FY33VC, FY33VCX-12, FY33VCX-8

Gerber Solara ION

Grapo Manta KM8 720UV

Infiniti Fina-160, Fina-250, Fina-320

Inwear Inwear-KH, Inwear-KH6C, Inwear-KHE, Inwear-KHE6C, Inwear-KNE, Inwear-KNEGC,
Inwear-SG30, Inwear-SG306C, Inwear-SG50, Inwear-SG506C, Inwear-SG80, Inwear-SG806C,



Inwear-SN, Inwear-SN6C, Inwear-SW, Inwear-SW6C, Inwear-X, Inwear-X6C, Inwear-XL,
Inwear-XL6C

Mutoh RJ-900 Pro (DrafStation Pro), VJ-1608 Flatbed (ValuedJet), VJ-1608 Roll (ValueJet)
Neolt SuperJet M 2050, SuperJet M 2500. SuperJet M 3200

Roland AdvancedJET AJ-740, SOLJET PRO lII XJ-540, SOLJET PRO lll XJ-640, SOLJET PRO
[l XJ-740

Seaband SB-D2-X, SB-K3-K, SB-K3-X, SB-KD3-S, SB-KD3-X, SB-M2-X, SB-M3-K, SB-T1-K
SidRacing SID XC-250 4C, SID XC-250 6C, SID XC-320 4C, SID XC-320 6C, SID XE-180 6C,
SID XE-320 6C, SID XQ-180 6C

Wit-Color Digital Ultra 720+, Ultra 720T, Ultra Nova256H8, Ultra Silver H8, Ultra2000,
Ultrasky128H12-3300, Ultrasky128H16-3300, Wit2000H4 Fly, Wit2000H6 Fly, Wit6720T Fly,
Wit720+H12 Fly, Wit720+H16 Fly, Wit720+H4 Fly, Wit720+H8 Fly, Wit720T12 Fly, Wit720T16
Fly, Wit720T4 Fly, Wit720T8 Fly, WitNova256H8 Fly, WitNova6256H12 Fly, WitSky128H12 Fly,
WitSky128H16 Fly

New Engraver Drivers

Gravograph*: IS 200 Binary, 1S 400 Binary, IS 6000 Binary, IS 6000XP Binary, IS 700 Binary, IS
7000 Binary, IS 7000XP Binary, IS 8000 Binary, IS 8000XP Binary

New Hermes™*: IS 200 Binary, IS 400 Binary, IS 6000 Binary, IS 6000XP Binary, IS 700 Binary, IS
7000 Binary, IS 7000XP Binary, IS 8000 Binary, IS 8000XP Binary

Quality One: Concept 2000 12x12, Concept 2000 13x13, Concept 2000 14x16, Concept 2000
16x16, Concept 2000 17x17

*Gravograph / New Hermes Binary models require HPGL2BIN utility be purchased from Gravograph /

New Hermes to drive these machines.
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Installer

This readme file no longer appears during installation. It is loose on the DVD, and will also install
to the \Readme folder.

Fonts and Graphics CD is included with over 500 fonts and 2500 clipart images in Flexi format.
Full support has been added for Windows Vista 32 and 64 bit versions added.

Support for Windows 2000 has been dropped. Thought the product can still install and run in this
environment, it is not longer officially supported by SA International.

Installer will no longer allow installation on Windows 95, 95, or ME.

A DVD drive is required to install the software.

Software no longer requires administrative rights to operate when using Windows Vista.
Windows XP and Vista store hot folders and preferences in C:\Program Files\SAi\SAi Production
Suite\Jobs and Settings folder.

Software now installs to C:\Program Files\SAiI\SAi Production Suite

SHK key driver has been updated to version 7.4.0.

Hasp key driver has been updated to version 5.25.

All sample files now install regardless of product level.

All help files and readme files now install to the \Help folder.

Windows 2000 may not show PostScript or Adobe PDF import because psih.dll is not loading. In
this case GDlIplus needs to be installed. That can be found on the DVD by running Uti\Windows
2000 GDIplus\gdiplus_dnld.exe. The installer will automatically install the missing DLL if it cannot
be found on your Windows installation. On launch you must set the path to \Windows\System32.
ICC profiles can now be installed regardless of the product level.

Installer now gives a warning message if you don't have Windows 2000 128 bit encryption
installed.



SAi_Color_Tester07.pdf now installs loose to the Samples folder. This file can be used to verify
the quality of an ICC profile.

Install Manager

The installer no longer requires a user number and password to install. At the end of installation
the Install Manager application is automatically launched. Here you enter the application
password along with any optional passwords. The Install Manager allows you to change the
software language, switch to demo mode, and even change the product level (for NFR
passwords). The Install Manager replaces the Install Password application.

Install Manager will report back the user ID based on the password entered.

Switching to demo mode in the Install Manager will automatically input a demo password.
Switching back to non-demo mode will automatically re-enter your original password.
Upgrading to a higher level product can be done without needing to re-install the software. Simply
enter the new password in the Install Manager and re-launch the application.

Switching applications may leave old icons on desktop. Press F5 to refresh the desktop.

New product shipments will include a new password for softkey activation. Softkey requires that
you have an internet connection every 30 days in order to register and activate your software.
Upgrades require that the license be transferred from the old key to the new key. This process
will disable the old key.

After registering software with a softkey, you will be provided with a registration ID. Write this ID
down and use it if you ever need to re-install this product or any other SAi product. This way you
will not need to re-enter your registration details.

In order to change the registration details, choose Help>Registration>Edit Registration. This will
transmit a new set of data and requires an internet connection.

You can deactivate the softkey on one system if you need to move it to another. Use
Help>Registration>Transfer License to deactivate the product on the system, then you can
activate it on anther. Softkey only allows for one active activation.

Keep your softkey password safe. This is the license to use the product. If someone else gets
hold of it, they can install and activate on their system before you do.

Only SafeNet Sentinel Hardware Keys (SHK) and Soft Keys are supported in this release.

SHK keys now support remote desktop.

NFR products now include the engrave option.

Closed a security hole in the SHK security.

Flexi Changes

Auto Updates - The software will periodically check for any new updates on launch and informs
you when they are ready to download. Check for updates immediately by choosing Help>Check
for Updates. For SHK users, updates need to be checked manually by selecting Help>Check for
updates.

Autodimension now includes a DesignCentral page to include strokes and to select which corner
to place the measurements.

Pressing arrow keys during path segment selection will now move the segment and not the entire
path.

Blend effect now preserves colorspace of objects.

Files saved now use the extension fs or pd instead of FS or PD.

Opening a Casmate file no longer places all objects in a group. Note, that on import a group is
automatically made for all files.

Auto serialization objects can now be ungrouped in order to edit a part of the job.

Send Email as JPEG or PDF will now always display options dialog.

Bitmap Edit Tools will now work with bitmap images on 90 degree rotations.

Sample file that install now include Job Info in order to demonstrate templates.

Distribution toolbar has been rearranged to follow order in the menu.



Multiple FS files can now be opened at one time.

Add to swatch table and transform with object options are no longer shown in gradient properties
dialog when no object is selected. These options are object specific and are not stored with the
gradient definition.

Windows thumbnail image for Flexi files is now higher resolution and smoother to better view the
files.

Snap now allows snapping at the intersection of two guidelines, and snapping when using the
bezier path tool.

True Shape Nesting no longer re-calculates on clicking apply.

True Shape Nesting no longer breaks groups apart.

Select Tool now selects within groups when other objects inside the group are hidden with the
view filter.

Import / Export Changes

Importing EPS files no longer create as many masks

EPS files exported from Flexi can now recognize spot colors in order to use spot color mapping.
PDF export has new option "Export Substrate" in order to export the drawing area and substrate
color.

Adobe AI/EPS import of some files no longer shows holes inside the object.

DXF import no longer skips the last segment of each path.

DXF import now supports complex geometry. (quadratic and cubic splines)

Export as PDF no longer crashes if there are lenses on non-RGB images.

Color Changes

Color name appended to the tool tip of stroke color

Metamark color libraries have been added.

Roland Color System Library has been added.

Measure Color has been added to FlexiPRINT and CUT

“Merge from document” has been modified to merge the colors with same information (including
name, color value, vendor, type #, part #) to one.

Pattern fills are now drawn more accurately on screen.

Text Changes

DesignCentral can now display more fonts without scrolling, and scroll bar no longer appears off
the edge of the screen.

It is now much easier to click the text tool inside an existing block of text, especially when the text
is small.

Improved scrolling of fonts in DesignCentral using arrow keys.

On screen spell check is less sensitive about where you right-click, especially during text
creation.

Stroke fonts have been renamed to start with the letter "E". For example, Baha 1 is now E Baha
1. Documents that use the original font name will be automatically substituted to use the new
name.

Insert symbol no longer shows characters that cannot be inserted in the first two rows of the
dialog.

Converting Braille to text no longer offsets the text from the position of the Braille.

Braille now defaults to lowercase.

Full Justify can now be properly disabled.

Bug Fixes

Registration marks no longer disappear after using the view filter.

Flexi no longer freezes when resizing certain patterns.

Z resolution for engravers now displays properly when units are set to metric.
Import of multiple Casmate files no longer causes Flexi to exit.



Label text no longer offsets if too long.

Island fill has been improved to not leaves holes in some objects, or skip other objects.

Outline has been improved to give the correct result for certain paths.

Auto Serialization no longer crashes when system32\MSFLXGRD.OCX is not registered.

Auto Serialization will no longer freeze when using stroke text with medium kerning.

Auto Serialization will no longer split text at a symbol such as $ or (). It only splits text at a space.
Degree symbol in DesignCentral is no longer corrupted when regional setting is partially set to a
2-byte locale.

Icons are now retained after customizing the Flexi 7.x workspace.

Dimension tools now properly store default settings.

Multiple copies of drill points now output correctly

Bitmap>Make transparent now works on large bitmaps.

Production Manager will no longer freeze on launch due to an SHK driver issue.

Improved compatibility with Photoshop plugin filters.

Output to a desktop printer will no longer be offset when Selection Only is enabled.

Cut/Plot, RIP and Print and Engrave Output Changes

Apply color correction in Production Manager option has been added to the advanced tab of the
RIP and Print dialog. When enabled, color management will be performed by Production
Manager, however any individual input profiles and rendering intents are discarded, and only the
settings made in Edit>Color Settings are used.

Repeat job has been added to the advanced tab of RIP and Print in order to repeat the output of
a job. This can be used to enable a job to be trimmed after each row of copies.

Clicking Properties button in Cut/Plot or RIP and Print will now open Default Job Properties
instead of Setup Properties.

RIP and Print can only connect to Production Manager for PhotoPRINT 6.x and Flexi 8.x.
Weedlines no longer go though inside of letters (a, e, even u and m).

Cut lines are no longer created across objects that cross a vertical tile line.

Option added to Cut/Plot to cut strip crossings. This option defaults to on, but can be turned off
when cutting large stencils.

Panel margin added to RIP and Print contour cut dialog

Weed lines/split lines are now automatically rotated when the job is rotated.

“Panel to border” button on the Panel page has now been replaced with a “Panel to border”
checkbox and the state of it is saved.

Easy Weed has been added back to the options tab of Cut/Plot.

Improved layout of multiple copies of a contour job so that the output matches the preview in RIP
and Print dialog.

Engrave output now shares a single panel for all tools.

FlexiENGRAVE now includes auto serialize command.

Engrave option now includes auto serialize command.

Engrave option no longer includes true shape nesting. This feature was included as part of a
promotion with the initial release of the FIexiENGRAVE product line.

Engrave fill commands now properly store default settings.

Fixed a bug where offset cannot be changed by dragging the design in File>Engrave dialog.
Driver options set in Cut/Plot and Engrave are now preserved after using Selection Only option.

New Production Manager Features

Desktop printing - Option added to install a desktop printer driver each time you add a color
printer setup. The desktop printer contains all installed presets and ICC profiles so you can
choose from any available. Setup properties has button to install desktop driver if you need to
create a desktop printer driver with the current settings.

Output size compensation now is available in Production Manager for all products, not just RIP
products.

The preview in job properties can now be dragged to change the scale of the file. Drag a corner



handle to scale proportionally, or drag an edge handle to scale non-proportionally. Double click
the preview to rotate the file.

The RIP log as been changed to an output log. Instead on only logging each time a file is RIPed,
now each time a file is sent to the output device a log entry will be created. This allows you to
have better reporting of all jobs that are output regardless of whether they required a RIP.
Variations - Variations allows you to adjust the hue along with saturation, brightness and
vividness while viewing the results on screen in a dynamic dialog.

Edit - You can now edit files in the queue using any installed graphic application (Photoshop,
Corel, Acrobat, etc). After editing, the revised file will be automatically in the queue.

Improved variable dot dithering when using "Error Diffusion 2"- New dithering has been optimized
for use on variable dot printers in order to achieve the smoothest possible output.

Workflow presets - presets are no longer required in order to store driver options and CMS
settings with a color profile. These settings are now built into the ICC profile. Workflow presets
are optional settings that store all settings. Presets can be selected at the top of all tabs in the job
properties dialog. If any settings in the workflow preset conflict with settings stored in the ICC
profile, an alert icon will be shown by the relevant fields.

Easier preset management - Save, save as, rename and delete are now available as buttons
besides the preset selection.

Recent file list - the 10 previously added jobs will appear in the recent file list if you need to
quickly re-add one of them to the queue.

Queue customization - The column headings can be re-arranged by dragging, and can be shown
or hidden by right clicking on the heading and selecting field chooser.

Basic Job Properties - An efficient way to set all essential parameters in a single dialog box
without having to page though each tab of job properties. To change the view to full job
properties, click on the advanced job properties button at the left side of the dialog.

Duplicate Setup - An existing setup can be duplicated with the same manufacturer, model and
port. This is useful when adding setups each with different default job properties in order to
customize the workflow. Click on the setup in the left pane of Production Manager to duplicate.
Output Validation - Hewlett Packard Z2000 and Z3100 drivers support output validation. This
feature will print a confidence strip that can be compared to an initial reading to report when the
colors stray due to banding, media changes, or environmental changes. The strip will be
automatically printed and measured, and you can select the alert level. The printer must be
connected via USB or TCP/IP in order to use this command.

Open Job Properties - Option added to add job dialog to immediately edit the file in job properties.
Immediate access to Job Properties - Job Properties can now be opened immediately while the
preview is still loading. Some options such as driver options can be change without the preview.
Options such as media size are dimmed.

Read only Job Properties - Job properties can now be opened to review settings while a job is
RIPing or outputting. This allows you to confirm the correct settings were made without having to
abort the job.

Job Estimation - You can now calculate the cost of a job based on material usage plus services
such as mounting and lamination. Create your own pricing structure and even add custom
services such as delivery. Estimation can be done for an existing job, or before a job is added to
provide a client a price over the phone.

Support added for Dual Rolls of media loaded onto the printer. This can be enabled by turning on
Dual Roll in the General tab of Job Properties.

TWAIN scanning added in order to directly add jobs to the queue.

Object Color Control now allows for a tolerance to be set for the input color. This enables colors
in anti-aliased bitmaps to be remapped to a solid color.

CutContour layer is now supported for AutoCAD files.

Color mapping button has been removed from the Setup menu and can now be accessed from
the Color Management tab of Default Job Properties.

Color mapping is now stored as part of a preset.

Repeat job has been added to the workflow tab of job properties in order to repeat the output of a
job. This can be used to enable a job to be trimmed after each row of copies.



RIP error no longer occurs on processing of some Photoshop PSD files that are added directly to
the queue.

Object Color Control now samples correct color when print is mirrored.

Using a dither type with a localized name no longer causes ink limits to be ignored.

New Production Manager Look

Setup column added to Production Manager.

RAM, Virtual Memory and HD usage are now shown with graphical icons at the bottom of the
queue. plus now supports systems with over 4GB.

New Windows Vista style toolbar and toolbar menus include options for nearly all operations.
Color scheme has changed and is reflected on all buttons and Ul elements within the software.
Only a single set of column headings are shown to allow for more jobs to appear in the queue
without scrolling.

Add setup dialog has been overhauled. It now defaults to adding a setup based on which ICC
profiles you installed.

Port settings are now set in the Change Port dialog, accessible from Setup>Change Device Port.
Save preset dialog box now shows icons for each tab.

IP address is now shown after the setup name in the device bar.

Date is now shown in the job queue.

Production Manager Nesting

Job nesting algorithm has been improved to be more efficient in order to save media.

Nested jobs now show as a hierarchy in the queue with the parent job showing the number of
items in the nest.

Each job in a nest can now be edited without having to unnest then renest the job. You can set
number of copies, change size, etc. This can be done by double clicking a nest job child in the
queue, or by clicking on the nest parent job and then selecting the individual job within the
preview area. Changes made to the parent job will apply to all jobs such as media size and driver
options.

Changing copy spacing will now reset the nesting so that the spacing can be applied.

Color Profiler

The color profiler has been completely redesigned in order to optimize the workflow of creating a
new ICC profile.

Color profiles no longer have a separate TRC linearization table. The linearization data is now
stored in the ICC profile.

Gray balance can now be measured and compensated for.

ICC profiles can now be stored in either ICC version 2.1 or 4.0 format.

Flexi 7.x and 8.x profiles and presets are not compatible with 8.5. They need to be converted to
the new format in order to be used. Flexi 7.x and 8.x presets can be converted and used, and
other ICC profiles can be imported as measurement data. There is a button in the color profiler
welcome page that steps you though this process.

Barbieri now supports fast scan mode.

Ink limit test target has been changed to make it easier to find the point of ink bleeding.
Linearization now prints additional swatches at the highlights and shadows in order to improve
output smoothness.

The profiler wizard can be stopped and resumed after any stage, and even put in the background
in order to continue using Production Manager.

Full support has been added for N-color devices such as devices that print CMYKRGB plus light
inks. ICC profiles can now be created for these new color modes.

Spot color rendering intent is no longer supported. Use Saturation intent as a substitute to get the
most vibrant prints.

Added support for X-Rite Eye-one on 64bit OSes.

New media can only be added in the color profiler. Job properties only allows media selection.



. Multiple profiles can now be added in Job Properties by selecting add from the output profile

combo.

. Pure Hue option has been removed. It is now always enabled.

. Custom Color Mapping has been removed from setup menu and placed in the Color
Management tab of Job Properties so that it can be stored with the preset.

. Support added for X-Rite ISIS colorimeter.

. Support added for HP Z2100, Z3100 and Z6100 as colorimeters.

New Cutter Drivers

) Asbru COMPACT 30 PLUS, COMPACT 54 PLUS, COMPACT PRO

. Copam CP-2500, CP-3050, CP-3500, CP-4050, CP-4500

) Creation-PCut CR-1200, CR-1200 DMPL, CR-1500, CR-1500 DMPL, CR-630, CR-630 DMPL,
CR-900, CR-900 DMPL, CRN-1200, CRN-1500, CRN-630, CRN-900, MCR 270

o Foison C12, C24, C36, C48, S12, S12-USB, S24, S24-USB, S36, S36-USB, S48, S48-USB

. GCC SignArt Nautilus NL-P

. Graphtec FC7000-60, FC7000MK2-100, FC7000MK2-130, FC7000MK2-160, FC7000MK2-60,
FC7000MK2-75

o iCut iCut

o RedSail Tech RS1120C, RS1360C, RS360C, RS450C, RS720C, RS800C

. Roland VersaCAMM VP-300, VersaCAMM VP-540

. Wild TA10BL Manual Feed, TA2L Signtronic

o Zund XL-1600Laser

New Printer Drivers

o Asbru COMPACT 30 PLUS, COMPACT 54 PLUS, COMPACT PRO

. Canon imagePROGRAF iPF5100, imagePROGRAF iPF610, imagePROGRAF iPF6100

. ColorSpan ColorSpan 5440UV, ColorSpan 5445UV, ColorSpan 5460UV, ColorSpan 5465UV

) Crystaldet CJ-F3312A, CJ-F3312B, CJ-S3312B

. Design Design K2504, Design K2506, Design K2508, Design K2512, Design K3306, Design

K3308, Design K3312, Design SN3304, Design SN3308, Design SS3308, Design SS3312,
Design X1804, Design X1806, Design X1812, Design X1816, Design X2506, Design X2508,
Design X2512, Design X2516, Design X3306, Design X3308, Design X3312, Design X3316

o DGI DR-1904T, DR-1906, SG-1806, ST-1806

. Digital Photonics CDJet, CoJet 2412

. Eastech EZ-10206, EZ-4804, EZ-6404

. Epson PX-5800, Stylus Pro 11880, Stylus Pro 3800, Stylus Pro 3800C, Stylus Pro 3850

o Fei Yeung Union FY-1804S, FY-1806S, FY-182C, FY-183B, FY-212C, FY-213B, FY-252C,
FY-253B, FY-322C, FY-323B

. GCC SignArt Nautilus NL-P, StellarJET 250UV

. Graphtec SignJet Pro JS500-18ES, SignJet Pro JS500-25ES, SignJet Pro JS501-18ES, SignJet
Pro JS501-25ES

. Hewlett-Packard Designdet T1100 24, DesignJet T1100 44, DesignJet T610 24, DesignJet T610

44, Designdet 22100 24, DesignJet Z2100 44, DesignJet Z3100 24, Designdet Z3100 44,
DesignJet Z6100 42, DesignJet Z6100 60

o Hi-Jet S6320 4C, S6320 6C, X6320-A 4C, X6320-A 6C
. Infiniti YF-8160X
. JinHengFeng VISTA 04E, VISTA 06ES, Vista A3304F, Vista A3304FN, Vista A3306FNS, Vista

A3306FS, Vista A3308F, Vista A3308FN, Vista UM3304D, Vista UM3306DS, Vista UM3308D,
VISTA UV08D+, Vista V1206FNS, Vista V3304FN, Vista V3306FNS, Vista V3308F, Vista



V3308FN

Leopard C3304F, C3304FN, C3306FNS, C3306FS, C3308F, C3308FN, UM3304F, UM3304FN,
UM3306FNS, UM3306FS, UM3308F, UM3308FN

Meidet MJ Konica SLX308, MJ XJ128-360

Mimaki JF-1610, JF-1631, JV33-130, JV33-160, JV5-260S, JV5-320S

Mutoh PJ-1946NX (Osprey 75), PJ-2646NX (Osprey 102), Rockhopper 3 65, Rockhopper 3 90,
Viper 65, Viper 90, Viper TX 65, Viper TX 90, VJ-1304 (Valuedet)

New Color NJ-1804N, NJ-1806N, NJ-2004N, NJ-2006N, NJ-2504, NJ-3308, NJ-3308N, RJ-3316
Phaeton UD-1804S, UD-1806S, UD-182C, UD-183B, UD-212C, UD-213B, UD-252C, UD-253B,
UD-322C, UD-323B

Roland VersaCAMM VP-300, VersaCAMM VP-540

Sakurai HOTARUJET HJ-1204

Seiko Instruments ColorPainter 100S PROGEAR (IP-6900), ColorPainter 64S GEAR (IP-5600),
ColorPainter 64S PROGEAR (IP-6610), IPE-3020, IPE-3120, LP-1010, LP-1010MF

ShenWu SW-3312U-4C

Sky Air SKYKJET-2600UV-5C, SKYKJET-2600UV-7C

Teckwin TeckLight 3200, TeckPro 3000, TeckPro H3200-4x3a, TeckPro H5000S, TeckPro
S3200-1, TeckSmart UV1600 x300, TeckStar, TeckStone S3200, TeckUV S3000, TeckUV1000
Titan TT-1808, TT-2612, TT-3312, TT-3316, TT-3516, TT-5000

Wit-Color Digital Ultra 1000-380-6C Fly, Ultra 1000-380-8C Fly

Xerox 8265, 8290, 8365, 8390

Yaselan YSL-D1600FB-4, YSL-D1600FB-6

Yishan YS3206-DI, YS3504-CA, YS3504-EC

ZhongNuo COLORQ3304, COLORQ3306, COLORQ3308, COLORQ3312-4, COLORQ3312-6,
COLORQ3316
Zund UVjet 250

New Engraver Drivers

Aristo GL 2032-8, GL 2232-8, GL 3132-8, GL 3152-8, TL 1310-8, TL 1617-8, TL 1625-8

Gerber Dimension 200

Gravograph 1S200, 1S400, 1S400 Volume, 1S6000, IS6000XP, 1S700, 1IS7000, IS7000XP, 1S8000,
IS8000XP, Vanguard 3000, Vanguard 3400, Vanguard 7000, Vanguard 7200, Vanguard 9000,
Vanguard 9200

MultiCam 101, 103, 204, 304, MC22, MC22 Plus, MC44, MT1M, MT22

Roland MDX-15, MDX-20, MDX-40, MDX-540, MDX-650

Driver Changes

Vinyl Master drivers have been renamed to Desay.

Machine Automation drivers have been renamed to Multicam and are listed in add setup as
engravers.

Spot colors are no longer swapped on the Summa DC3 / DC4.

Contour job is on longer mirrored on the Summa DC3 / DC4.

Summa DC4 now can support up to 8 spot colors in a job.

Mimaki JV5 now prints with the correct job offset when using 2-bit colormodes.

Mimaki JV3 / JV4 now better handle timeout so that the job will not stop if the printer is offline for
an extended period.

Canon printers now have support for full colormode support (CMYKRGB)

Roland GX-24 now honors advance after plot setting.

New Hermes Vanguard drivers now output holes properly when depth is disabled.

Graphtec FC7000 and CE5000 now include a driver option to set the cutting condition in order to



use settings configured on the cutter.

Graphtec FC7000 and CE5000 now properly support the cross cut option in the after job tab of
cutter driver options.

Roland VersaCamm SP 540V now has BillBoard print mode for high speed printing.

Graphtec FC7000 no longer prints segment area marks in the wrong direction.

Graphtec FC7000 cross cut driver option now operates properly.

Summa USB port can now be detected with Windows Vista.

New Hermes and Gravograph drivers now include driver option "Pause before engraving".
New Hermes: Dwell time setting is now sent to the device.

Roland GX cutters

The GX cutter will no longer need to be in Rotate 90 mode in order to cut. You can set the cutter
to Rotate 0 (the default hardware setting) and it will now work for both regular cutting and contour
cutting.

Poll size no longer swaps material width and height.

When opening the Cut/Plot dialog box, we now show the preview at the lower left corner with zero
offset. Dragging it to the right will increase the offset amount. This is behavior similar to Cut
Studio.

Contour cut marks design has been tweaked so that there are no longer a series of arrows at the
end of the print. Instead, the first mark is indicated with a small arrow to indicate where to position
the cutter before starting the mark detection.

All 4 marks are now detected for better accuracy. The current release detects only 3 marks which
could lead to some inaccuracies.

Contour cut can now be up to the maximum of 1.5M instead of 762cm because we no longer
require the print job to be loaded into the cutter sideways. That removes the software limitation
and allows us to cut to the full length supported on the hardware.

FlexiFAMILY 8.1v1
Build 1115
November 15, 2006

Changes

Barbieri Spectro LFP now allows manual swatch alignment.

Engraving option can now be unlocked for any level FlexiSIGN family product.

True Shape Nesting no longer has a limit of 100 copies. It can now go up to 1000 copies.
Diagonal selection now works on compounds.

Tangential entry/exit tool on path edit toolbar has been removed.

Desktop icon now installs for all users, not just the current user.

Duxbury Braille option is no longer available. We have switched to another Braille that allows us
to have additional languages.

Added support for EnRoute contour cutting. To use this add "EnRoute" device in Production
Manager and output the job using RIP and Print. The contour job will then be sent to the installed
copy of EnRoute. This requires a new release of EnRoute to properly detect the alignment marks.
NFR passwords now allow FlexiENGRAVE and FlexENGRAVE-PRO to be installed.

Arabic CasFonts are now supported

User manual has been updated and localized in all languages.

Gretag IO DLLs have been updated to the latest version to support the newest driver.

Output to a laser engraver no longer places an extra outline around stroked objects.

Connection to a remote Production Manager no longer shows multiple of the same Production
Manager in the list.

Desktop print "selection only" no longer shifts the print on the page.

Poll size now works properly with USB port connection.

Cut/plot dialog now has up/down buttons besides the color list on the options tab.



New Cutter Drivers

Desay: Tiger 1000, Tiger 2000, Tiger 3000, XY-300P, XY-380P, XY-450P, XY-520, XY-540P,
XY-660P

GCC: SignPal Bengal BN-60, SignPal Sable SB-60

Roland: GX-300. GX-400, GX-500

Uniform: Cadet Plus

Vinyl Express: Enduracut, Enduracut +, QE60 +

New Printer Drivers

Astro: Astro DS1804F, Astro DS1806S, Astro DS1808F, Astro DS2506S, Astro DS2508F, Astro
DS25128S, Astro DS2516F, Astro DS3206S, Astro DS3208F, Astro DS3212S, Astro DS3216F
Canon imagePROGRAF iPF5000, imagePROGRAF iPF8000, imagePROGRAF iPF9000 (6 color
support only)

ChiTing: ChiTing Konica-512, ChiTing Spectra-256, ChiTing Xaar-126, ChiTing Xaar-128,
ChiTing Xaar-128+

DGI: PS-3206, XP-3204T

Eastech: Austrina PCA-6400, Austrina PCA-8700, Corona T-1004, Corona T-1008, Corona
T-2008, Corona T-400, Corona T-800, Corona TS-1008, Corona TS-2008

Fei Yeung Union: FY-2104S, FY-2106S

Fujifilm: Kaleida GP171ll, Kaleida GP24lIl, Kaleida GP44llI

GCC: StellarJet 183UV, StellarJet 250UV

GongZheng: GongZheng GZC-XJ-4C, GongZheng GZC-XJ-6C, GongZheng
GZC-XL-4C,GongZheng GZC-XL-6C, GongZheng GZD-XL-4C, GongZheng GZD-XL-6C,
GongZheng GZF-3204S, GongZheng GZF-3206S

Graphtec: SignJet Pro JS310-18ES, SignJet Pro JS310-25ES

Hewlett-Packard: DesignJet 100, Designdet 10000s, DesignJet 110, DesignJet 110, DesignJet
70, DesignJet 8000s, DesignJet Z2100 24, DesignJet Z2100 44

Hi-Jet: S6250 4C, S6250 6C, X6250-A 4C, X6250-A 6C

Human Digital: Q-Jet Plus HM3200

JinHengFeng: Vista 04E, VISTA UM3304D, VISTA UM3306DS, VISTA UM3308D, VISTA
UV2504D+, Vista V3304E, Vista V3304F, Vista V3306ES, Vista V3306FS

Kwangko System: Sprin Wiz20, Sprin Wiz26, Sprin Wiz32

MaxPrinter: XP834, XP844

Mutoh: PJ-3346NX (Osprey 130), RJ-900 (DrafStation), RJ-901 (DrafStation)VJ-1604 (ValuelJet),
VH-2606 (ValueJet)

Phaeton: UD-2104S, UD-2106SUD-2504S, UD-2506S, UD-3204S, UD-3206S

Roland: Hi-Fi Express FP-740

Seiko Instruments: ColorPainter 64S Light (IP-5600), ColorPainter 64S Plus (IP-6610)
ShenWu: SW-3304, SW-3304U, SW-3304U+, SW-3306, SW-3306U, SW-3306U+, SW-3308U,
SW-3308U+, SW-3312U-4C+, SW-3312U-6C, SW-3312U-6C+, SW-3316U, SW-3316U+,
SW-3504U, SW-3506U

Summa: DC4sx

Uniform: Cadet Plus

Yishan: YS2407-EB, YS2504, YS2506-DI, YS2506-DJ, YS3204, YS3206, YS3504-CA-C,
YS3506-4-EA-C, YS3506-CF, YS3506-EA-C, YS3508-EE

ZhongYe: ZY-1904, ZY-1908, ZY-2608, ZY-2612, ZY-2908, ZY-2912, ZY-3300, ZY-3308,
ZY-3312, ZY-3312 6C, ZY-3316, ZY-5300 4C, ZY-5300 6C, ZY-5316, ZY-5324, ZY-7208,
ZY-7212, ZY-7216

Zund: UVjet 215PIu

New Engraver Drivers
New Hermes: Vanguard 3000, Vanguard 3400, Vanguard 7000, Vanguard 7200, Vanguard 9000,
Vanguard 9200



Driver Changes

HengXing renamed to King Rabbit

Grapthec FC7000 and CE5000 now support trimmer.

Liyu drivers are now password protected.

Graphtec Multi-Segment contour cut alignment mark support has been added.

Epson Stylus Pro 4400, 4800, 9400 and 9800 no longer give a mismatch error when printing a
color profile swatch print.

Roland SOLJET PRO IIl XC-540 now supports automatic registration mark detection

Summa DC4 now properly aligns the cut with the print.

Summa DC3/DC4 now allow up to 8 spot colors in a job.

Modified Features

Toolbar>Path Edit>Round Corner now has an option to round all corners, selected corners, inside
corners or outside corners.

Auto serialization layout can now be changed in DesignCentral and spacing is based on
serialization result.

Files with any new objects cannot be opened in Flexi 8.0. In order to open these files use
File>Export and choose "Flexi 7.5" from the format list.

Convert to shape command will now convert all objects in a group to the specified shape.
Text>Braille has been optimized to work with engraving. There is no longer a menu command to
choose Grade 1 or Grade 2, instead these are set in DesignCentral. DesignCentral for Braille now
has an option to drill, fill or laser the Braille dots. For drill, apply hole fill. For fill apply hatch or
island fill.

Braille now supports Text>Break Apart.

Text>Justification>Full now as a "Compression only" option to compress text to fix when adjust is
set to "Character Width" or "Character Size". A related option "Apply equal compression to all
lines" will calculate the compression needed for the longest line of the text block, and apply the
same compression to all lines. This works great with Auto Serialization to compress names that
are too long to fit a nametag.

Default kerning is now re-applied from the font if you select Text>Kerning>Default

Stroke Fonts

17 new stroke fonts have been added, for a total of 27 stroke fonts. The new stroke fonts are as
follows:

E Glacis 1

E Jasmine 2
E Lilac 1

E Palm 1

E Script 1

E Squill 2

E Tulip 1

E Tulip 4

E Orchid 2

E Cursive 1

E Iris Laser 1
E Iris 1

E Normal 1

E Roman 2

E Almond 1

E Cyclamen 2
E Glacis 4

Engraver Drivers (only available with Engrave Option)

New Hermes (Gravograph): 1S200, 1S400, 1S400 Volume, IS6000, IS6000XP, 1S700, IS7000,
IS7000XP, 1S8000, IS8000XP, Vanguard 3000, Vanguard 3400, Vanguard 7000, Vanguard 7200,



Vanguard 9000, Vanguard 9200

o Quality One: QSeries 1824, QSeries 2448
o Roland: EGX-20, EGX-30, EGX-300, EGX-400, EGX-600
. Vision Systems: Phoenix 1212 Series 1, Phoenix 1212 Series 2, Phoenix 1212 Series 3, Phoenix

1612 Series 1, Phoenix 1612 Series 2, VE-810, VE-810XD, Vision 1612 Series 3, Vision 1624
Series 1, Vision 1624 Series 2, Vision 1624 Series 3, Vision 2424 Series 1, Vision 2424 Series 2,
Vision 2424 Series 3, Vision 2448 Series 1, Vision 2448 Series 2, Vision 2448 Series 3, Vision
5252 Series 1, Vision 5252 Series 2, Vision 5252 Series 3, Vision Max Series 1, Vision Max
Series 2, Vision Max Series 3, Vision MaxPro

Auto Serialization Usage
. Apply toolpaths before using auto serialization. This way, you don't have to fill each resulting
nametag.

There are two ways to output a set of auto serialized nametags.

1. Output on a single sheet of substrate, and add cut lines to cut each one apart. For this method, turn on
"Cut lines between copies" in the engrave dialog. Set the material size to match the sheet size. If
there are more nametags than can fit on a single sheet, you will be prompted to insert another
sheet. Cut lines between copies will not work on auto serialized objects if they are converted to
outlines or removed from the serialization group.

2. Output on pre-cut nametags, and insert a new one in after each one is cut. For this method, set the
material size to match a single nametag. You will be prompted to insert another sheet for each
nametag. Detection of each individual nametag will not work on auto serialized objects if they are
converted to outlines or removed from the serialization group.

FlexiFAMILY 8.0v3
Build 1100
October 12, 2006

Installer

. Safenet SHK key driver has been updated to 7.3.1 to avoid a conflict with Gerber Omega and
Activity POS key detection. In some rare situations, this will not fully solve the issue, in that case
see SHK Omega Conflict below

. Safenet SHK key driver now fully supports 64 bit OS.

o Safenet SHK key is now automatically configured to allow an exception to the Windows XP
firewall.

. Xerox 8142 / 8160 ICC profiles are no longer included on the Output Profiles CD. They can be
found in the download section of the SAi website.

. Mimaki Firewire driver updated to version 2.10.

Localization

. Added Hebrew and Finnish languages.

. Localized versions can now apply templates.

. RIP error no longer occurs when Windows is set to use comma decimal separator.

. Hewlett-Packard DesignJet 9000s no longer shows empty message when printer requires
maintanance in localized versions.

° Rendering intents are no longer swapped in Japanese and Korean.

. Templates are now localized into all languages.

New Drivers

. Asbru: ASBRU_V1000

. Canon: imagePROGRAF iPF500, imagePROGRAF iPF600, imagePROGRAF iPF700
. Gerber: Solara UV 2



Graphtec: CE5000-60, CE5000-120, CraftROBO cc100-20, CraftROBO cc200-20, SignJet Pro
JS300-18ES

Hewlett-Packard: DesignJet 90

Mimaki: JV3-160SPIl, JV5-130S, JV5-160S

Mutoh: VJ-1204 (Valuedet), Phoenix E-MS, Phoenix S

Roland: SOLJET PRO Il XC-540

Summa: DC4

Vinyl Express: QE60, Q75, Q100, Q130, Q160

Driver Changes

Fixes

Rundiang Flora: Drivers are now password protected

Mimaki Firewire output can now be sent without any hesitation. Previously, there was a slight
delay between passes on some prints.

Mimaki JV3 160SP, JV3 160SPIl and JV3 75SPIlI now can share presets and profiles.
Foison FY 1808 no longer reports an error on opening job properties.

Hewlett-Packard DesignJet 9000s is no longer password protected.

Hewlett-Packard Designdet 9000s driver can now print to multiple printers simultaneously.
Roland GX-24: Poll size now returns correct media size.

Roland: Contour cut alignment marks now print uni-directional on printers that support direct
printing of these marks.

Seiko Colorpainter now supports SCSI output on 64bit Windows.

Summa: Added Flexcut option to D60, D120, DC3, DC4 and all S models.

No longer receive an out of memory error when copying transparent bitmaps.

True shape nesting now works properly on groups and on characters with external paths.
File>Save as has been added to Production Manager for FIexiEXPERT, FlexiLETTER and
FlexiSTARTER.

DXF export no longer produces files that are incompatible with Autocad.

Flexi no longer exits if there is a text block with only a space. This could occur after using the
Break Apart command or when clicking on text.

Passwords to unlock optional features now displays correct number of remaining hours with timed
keys.

Desktop print output to a laser engraver will no longer both raster and vector fill thick strokes.
They are now only raster filled.

If a file fails to fully save, an error message is now displayed.

No longer receive an out of memory error when copying transparent bitmaps.

It is no longer possible to set negative X and Y offsets in the File>Print dialog, which will cause an
error to appear when clicking OK.

JPEG files set to 0 DPI no longer give "Out of memory" error. They are now processed at 72 DPI.
Improved compatibility with Photoshop PSD files in Production Manager. PSD files that can be
imported into Flexi can now be directly processed by Production Manager.

It is now possible to use CMY output profiles to output in CMY color mode without an error
message.

WMF and PSD files can now be opened from directly from CD.

Global color mapping now prints correct color for Pantone spot colors

Files no longer fail to save properly after importing a file from removable media then
disconnecting the media.

Copying block text no longer causes a crash.

Connection to a remote Production Manager is now more reliable.

Adobe Acrobat can only support page sizes up to 200in. PDF export and Email as PDF now
automatically scale down any file that is too large for Acrobat to recognize.

DWG import filter has been improved.

Aborting a True Shape Nest no longer causes a crash.



Desktop printing now handles mirrored bitmaps when the printer driver does not have full support
for this internally.

Fixed a crash when opening some Flexi 5.x files with complex gradients.

The message, "There is not enough memory. Please exit the application", no longer erroneously
appears after unlocking Windows and returning to Flexi.

Launching Flexi by double-clicking a .FS file will no longer cause Flexi to crash.

Stability issues with smooth screen display have been resolved.

DesignEditor no longer causes an unknown error when running on two screens.

Native PLT files can now be sent from Production Manager for all product levels, not just
FlexiSIGN-PRO.

LAB colors (such as colors from the vinyl library) can now be printed to all PostScript Desktop
printers.

Flexi 5.x import now honors the font size set in preferences to set the size of imported text.
Desktop printing now outputs all rows of tiles.

FlexiFAMILY 8.0v2
Build 948
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Installer

Added support for language editions: Portuguese, French, Italian, German, Spanish, Simplified
Chinese, Traditional Chinese, Japanese, Korean and Dutch.

Demo version can now be installed by clicking on the Install Demo button in the password screen
of the installer, and now includes the word "Demo" in the application name. The demo version
defaults to installing FlexiSIGN-PRO.

Progress bar is now shown in a dialog during ICC profile installation.

FlexiSIGN now installs sample files

FlexiPRINT & CUT now prompts to view the readme during installation.

Installer now gives a warning message if you don't have Windows 2000 128 bit encryption
installed.

Hewlett-Packard DesignJdet 9000s ICC profiles now show up in output profile installer after
unlocking the driver.

Hewlett-Packard DesignJet 9000s driver now installs ECHOUSB.DLL and
ECHOUSBENTRY.DLL which are required to output to the USB port.

Web site address updated in Output Profiles Installer

Installer no longer defaults to clearing preferences.

Changing color mode in RIP and Print, then setting color adjustment curve will no longer crash.
Fixed a crash opening job properties for nested jobs sent from RIP and Print. Previously, jobs
sent from RIP and Print could not be nested.

Fixed a key detection problem during jobs that took a very long time to RIP.

Spectrocam colorimeter now allows USB port to be selected.

On screen spell check no longer reports and error when you add a space between two properly
spelled words.

Printing an LAB image with no ICC profile in Grayscale or CMYKLcLm mode no longer corrupts
the output.

Tip of the day and toolbar icons no longer show wrong size on some Windows 2000 systems.
Floating palettes can now be moved to a second monitor.

Seiko Colorpainter 64s (IP-6600) and Seiko Colorpainter 100s (IP-6900) now use "Color Painter"
as the ICC folder name.

Fixed a CPSI crash on processing of a corrupted PDF file.

Fixed a crash when changing any setting in job properties for a file with large number of pages.
NFR passwords no longer give an error message during installation "csm info list is empty" and



when Flexi is first launched.

240 hour grace period for upgrade keys now properly displays the number of hours left in the
opening screen.

Production Manager no longer has link to web site in the Help menu. It has been moved to the
About dialog.

Mimaki JV3-130SL: Vacuum setting in driver options can now be set.

Global color mapping was not applying properly to jobs with spot colors when "Use color
mapping" was enabled.

Timed passwords now display the correct number of remaining hours when time has expired.
True shape nesting now uses the drawing size as the panel size for nesting. This allows all
objects to fix into the nest.

Make right angle tool from the path edit palette has been moved away from round corner tools
and given a new icon.

Flexi .FS and .PD files with 2-byte names can now be added to Production Manager.
Graphtec contour cut alignment marks now print further from the image so that the image isn't
erroneously detected as the mark.

Italian dictionary now installs.

Crop tool is now available in FIexiEXPERT.

FlexiFAMILY 8.0v1
Build 921

April 21

, 2006

New Look

Design

Splash screen no longer displays the name of each plug in or font during the load process in
order to improve load time.

User name, company name, user number and password are no longer shown in the splash
screen. The user number and password are displayed in the Help>About dialog.

Tip of the day dialog redesigned, and now includes a back button to review previous tips.
Toolbar icons increased in size to be easier to view on high resolution displays.

Flexi 7x workspace will switch back to old icons.

Screen is automatically smoothed to remove jaggies. To disable screen smoothing, go to
Edit>Preferences

Preference added to save settings on exit. This is used to lock in the settings so they cannot be
changed.

Assign a shortcut key to any menu command or toolbar in File>Workspace>Customize.
Customized shortcuts are stored in C:\Program Files\Flexi\Profiles\Custom.upc

Color selector now shows full color name, instead of just a swatch. To switch back to swatch
view, choose "Palette view" in Edit>Preferences.

When in swatch view of color selector, each swatch is larger and more can be seen without
scrolling.

Combine tools and effects are now accessible from the toolbar

View tools have been re-arranged so that the main zoom tool is at the top.

Moved "Overprint" checkbox from DesignCentral to Fill/Stroke Editor.

Adding a new category to job estimation will no longer show "Type" as dimmed in some cases.
Fixed a crash in Color Specs if default table is closed.

Adobe Plug-in under the Bitmap menu in the CASmate workspace no longer stays grayed out.
Sending jobs from Mac to PC now keeps correct driver parameters (passes, etc.).

Snap to toolbar added to snap menu.

Setting pattern to 0 size no longer gives an endless loop of error messages.

Auto serialization no longer crashes in French.

Undo reduce points no longer scrambles points on screen.



Added option in Rulers and Grids dialog to show grid as dots instead of lines.

Improved compatibility with Photoshop plug ins so that application will no longer close or exit on
trying to change some settings.

New option added to the File Paths tab of Preferences to force software to always use the same
document folder.

Rasterize dialog that comes up when you send a lens to RIP, now shows more detailed
information on what will be rasterized and give progress bar. It defaults to 1/4 the printer
resolution.

Selecting a preset in RIP and Print dialog that uses a 3rd party ICC now will properly set the
linearization file and ink limits with RIP and Print.

Improved text handling in EPS/PS import filter.

Importing EPS or PS files now better recognized the font names and will not prompt for font
substitution if the font is already installed.

Auto-scroll as you drag near the edge of the screen has been optimized to accelerate as you
move further from the design.

Installing to a very long foldername no longer stops scilmport.dll from loading and causing a
crash.

. Snap to edge now properly snaps to the edge of the object during drag.

. Clicking with zoom tool will now re-center the image.

. Improved compatibility with previous version kerning.fkn files.

. Pantone colors no longer display muted when printed to an Acrobat PDF file.

. Sending a file from RIP and Print with an incorrect embedded ICC profile will no longer report
"Failed to initialize color management module". Instead, the incorrect ICC will be substituted with
a valid one.

. True shape nesting allows objects to be nested based on their shape, with an option to nest
inside holes.

. Job statistics shows details of entire job. Each object is listed along with position, size, area,
perimeter, color, plus font, size and number of characters. Selected objects will show selected in
the list and an export button allows object list to be saved as a text file.

. Group and Compound moved from combine toolbar to Group toolbar. The Group toolbar also
includes Mask.

o Rasterize dialog now has an option to add a margin of white space around the objects.

o Mask and Export added to context menu when right clicking on design area.

o Gerber Edge spectratone2.slb color library has been added.

Keys

o Only SafeNet Sentinel Hardware Keys (SHK) are supported in this release.

o Upgrades from Flexi 6.x and 7.x require that the license be transferred from the old key to the
new key. This process will disable the old key. You may request a password for the old version to
run on the new key, if needed.

. It is no longer necessary to run Flexi on the station with the key attached, before being able to run
a network copy of Production Manager. Sentinel Keys Server will automatically install with Flexi
so that the key can be found on the network even if you don't run Flexi first.

. Sentinel Keys Server will only work if an exception is setup in the Windows XP Firewall. Go to
Start>Control Panel>Windows Firewall and click on the Exceptions tab. Turn "Sentinel Keys
Server" on.

Templates

Apply template now has new options "Selection only", "Include Border" and "Include substrate
color".

Used colors and used fonts placeholders now allows line spacing to be specified.

Color and fonts of dimensions and labels will no longer be shown in template. In addition, overall
dimensions will not be affected by these objects.

Used Color Placeholder tool has an option to specify the swatch size.



Job info Placeholder tool now shows more items without scrolling in DesignCentral

Job info Placeholder tool now has options to insert Height, Width, Scale, Tax %, Subtotal. Scale
will show as a ratio such as 1:100 or 1:12.

After applying a template, all data from Job Info is automatically placed into the new design.
Active drawing placeholder has an option to set scale if desired (for example 25% or 1:10).

If multiple template objects are selected, they can be edited. Previously, DesignCentral would not
show any template data. This makes it easier to change the font for multiple items.

Template option has been removed from preferences>tools

Templates no longer show SA logo. Job Info template has been added and Job Info 2 template
has been renamed to Job Info 3.

There is no longer a shift between the text and the red outline that shows when text is selected.
Text>Justify menu added to select text justification. It is no longer necessary to set justification in
DesignCentral.

Easier incremental font selection in DesignCentral (type "ti" will go to times, not Tahoma, then
Impact)

On screen spell checking

Tabbed alignment

Import / Export

Export as Adobe PDF for customer proofing

Save / open layers for Al, DXF, HPGL, DWG

Smaller native .FS files via compression

Send to EnRoute improvements

Export as Flexi 7.5 added

File>Email as JPEG, PDF, or .FS

Documents default to my documents folder

Option to not update document location

Improved support of text in EPS/PS files

Improved kerning of CasMate files

Flexi .FS / .PD can be added into Production Manager to be printed or contour cut
Improved text spacing with Casmate SCV import.

Support added for PLT files from localized versions of Gerber Omega.

Cut/Plot Output

Advanced tab split into two tabs - Options and Advanced. Commonly used settings can be found
in options tab.

Cutter driver options now allows up to 10 custom cutter controls.

Driver options can be pre-set per color

Weedlines have an option to place the weedline though the center of an object (such as text).
This will cut across the text, but not into it, to make for fast weeding. Note that the orientation of
the weedline is based on the preview in the cut/plot dialog, not on the design area.

Easyweed option has been removed, since this can be achieved with weedlines.

Overcut option has been added to the advanced page of cut/plot. This forces the cutter to close
shapes by cutting along the shape by the specified amount when it reaches the end point.
Cut/Plot can only connect to Production Manager for PhotoPRINT 5.x and Flexi 8.x.

Tile all copies added to panel tab so that each copy can be tiled individually. This default to on for
flatbeds cutters so that final job requires no re-assembly.

Pause between colors dialog no longer allows custom command to be set.

Fit to media option added to general tab of Cut/Plot.

RIP and Print Output

Color adjustment curves added.



Presets are now shown as a list so that you don't have to open a dialog to select one.
RIP and Print can only connect to Production Manager for PhotoPRINT 5.x and Flexi 8.x.
Angled screen now always 1 bit regardless of print mode.
Automatic linearization selection has been improved:
1. If the ICC lists a TRC then use that TRC. If not then
2. If a TRC has the same name as the ICC, then use that TRC. If not then
3. Parse XML and find best match
Linearization file selected now shows in Job Properties. Previously, it always showed None,
though one was applied.
Toyo color libary added to global color mapping.

Desktop Printing Output

Complete overhaul of File>Print dialog now always shows preview and options in a single dialog.
Preview shows all tiles

Set position of image on page (center, corner or custom).

Set scale by entering a percent, or selecting a ratio from the list.

Apply a printing template, or create your own custom print template.

Job Info checkbox moved to a template "Job Info". Previously named "Job Info" is now "Job Info
2",

Turn on grid, guides and substrate printing without opening DesignEditor.

Output to a desktop printer with uneven DPI will no longer stretch the output.

Level Changes

Effects

FlexiEXPERT added bitmap crop

FlexiPRINT & CUT — PhotoPRINT DX plus FlexiSIGN with all drivers. Replaces VersaCamm
edition.

FlexiSIGN and FlexiLETTER added Select by attribute and Mask.

FlexiDESIGNER added Cut/Plot and RIP and Print to send to already installed Production
Manager. It will only connect to a Production Manager of FlexiSIGN-PRO or FIexiEXPERT.

Effects>Combine>Combine options command has been removed.

Weld by Color added to combine menu and combine toolbar. This will weld only objects of the
same color, and not convert all selected objects to the same color (formerly, this was done by
turning on "weld based on color" in combine options dialog)

Remove Overlap added to combine menu and combine toolbar. This will cut out, but keep the
cutting object (formerly, this was done by turning on "keep cut object" in combine options dialog)
Effects>Outline command now allows corner style to be set for line-curve intersections.

Multiple copies of Production Manager can now be run on the same system, they no longer
conflict with one another.

Exiting the software from the task bar when it is minimized, will no longer force it to launch
minimized the next time.

No longer crash on open .FS file with linked JPEG or TIFF that contains an embedded ICC
profile.

Outlining an object with several copies will no longer make circles between copies.

Outline of large objects now always has a consistent space between object and outline.

Color Management

Object Color Control - new tab added to Job Properties for Object Color Control. As the cursor is
moved over the preview, it will show the object type, colorspace, input value, and output value
with color management applied.

Clicking on the preview in Object Color Control will add a color mapping to the list and allow you



to change the output values.

Items in advanced color management dialog (rendering intents, input profiles) will dim based on
what objects are in the loaded file.

Vividness slider and Advanced button added to color adjustment tab of Job Properties.

Preview resolution in Job Properties can now be selected in preferences. The higher the quality
setting, the longer it will take to open job properties, but the less jagged image will appear when
zooming in. For nested jobs with many files, or for multiple page files with many pages, it is
recommended to set this to "Low" setting to reduce memory usage.

Gretag Eye-One SDK has been updated to improve performance. According to Gretag, this will
reduce the time before reading each strip and improve swatch recognition to improve scanning
accuracy. It also adds support for new "rev B. Eye-One Pro" colorimeter.

Spot color mapping table is now stored per setup, not per printer name. This makes it possible to
have multiple setups of the same device, each with their own mapping table.

Gradient smoothness (formerly smooth blends) now defaults to off to produce more accurate
results, and is only available if there are PostScript 3 gradients in the file.

Printer simulation now allows any ICC profile to be selected for simulation. It is no longer limited
to devices that have built in drivers.

Input ICC profiles DefCMYK.icm, DefGray.icm, and DefRGB.icm are no longer installed. These
were old default input profiles and new ones give better results.

Ink split was not always applied when printing profiling swatches for a new media.

Soft proofing in color adjustment tab now applies ICC profile changes without needing to turn
preview off then on again.

Shades of Pantone colors now print properly and get mapped to correct output color.

Ink limit is now applied to colors preserved in Pure Hue.

Jobs sent from Color Profiler are now immediately added to the queue. There were some cases
where the job would not show until product was re-launched.

) Added support for ink limiting of 3rd party profiles using CMYKOG

o Multiple ink limit test print now labels each row by the channel name.

o If the color profiler is not unlocked, then the device setup for colorimeter will be disabled.

) Driver options set in the first screen of the color profiler are now applied to the test prints.

o Improved profile creation workflow: You can now add media in the first dialog. After creating a
profile, you will be prompted to save a preset.

o Eye 1 beeps after each succesful strip. If there is an error it now beeps 3x

. Added support for new colorimeters — Gretag IcColor, Gretag 10, X-Rite DTP20, X-Rite DTP70,
Spectrocam USB, and Barbieri Spectro LFP

o Apply ink split to DCS files added to Job Properties. This option will re-combine DCS files so that
light inks can be printed.

Other Changes

RIP engine has been updated to Adobe CPSI 3017.102 for Windows.

RIP engine now supports CMYK overprint.

Removed preference for "Ignore overprint in PDF" has been renamed to "Ignore overprint" and
moved to Job Properties CMS tab.

Added "Borderless" checkbox to Layout tab of properties. When on it will only show borderless
media and selecting one will automatically fit image to that media to activate borderless printing.
Borderless is supported by some Epson, Canon and HP printers.

Updated to the latest version of the Microsoft compiler. This should improve performance,
memory usage and stability.

Fixed a thin black line that could appear between copies in some special cases.

Rotate image to fit media will now also rotate to save media, not just to save tiling.

Corrupted production preferences no longer cause a crash on startup. Instead, any corrupted
setups will be removed.

EPS files now show preview in Add Job in production

No longer receive message "There is already a setup with that setup name, share name, or hot



folder name." when trying to add some devices to production.

Media name in Job Properties no longer shows clipped.

Preference manager now can save properly even if Production Manager preferences aren't yet
saved.

"Print spot colors as process" checkbox moved from first page of separations to edit dialog for
spot colors as "Apply to all"

Angled screen now allows LPI values as low as 1.

Moire free button added to angled screen dialog.

Print mode can now be localized.

Cut tab of Properties dialog no longer gives an error if the number of steps is too high.

Fixed a crash when clicking "Save as default" for a cut job in job properties.

Output size compensation test print is no longer mirrored.

Page nesting now defaults to on so that multiple pages, tiles or separations are positioned to
save media.

Files can now be overwritten using Save As command from Production. Previously, original file
would be kept.

Color bands now print with an offset when the job is offset from the origin.

Driver Changes

Mutoh Ultima now supports multi-segment using firmware 3.00.

Mutoh cutter now works properly with trimmer.

Added support for contour cut alignment marks for Graphtec CE3000mk2.

Mutoh Ultima Cut Server application added to send out contour jobs from PLT files. This
application is only available for Windows.

Graphtec 3 point alignment marks removed since there is now support for 4 point.

Roland VersaCAMM and SOLJET PRO Il now supports 1-bit colormode for all resolutions.
Roland hybrid contour cut alignment mark no longer is activated by turning on "crop marks" from
driver options button. This mark can now be selected in Contour Cut dialog and the crop mark
option has been removed. The added advantage is that you can use any printer, then contour cut
on a Roland hybrid.

Roland SC-500: Newly added media now shows all possible print modes.

Roland printers now have correct number of passes shown in Ul. Previously, selecting 4 pass at
some resolutions would actually print 8 pass.

Cutter driver options now supports up to 10 custom controls.

ColorSpan drivers (S, SR, SRU, SX) can now be printed to by updating BCI toolkit updated from
3.61 to 3.63. Sl and UVR are not yet supported.

Full support for white ink on Mimaki and Roland printers. See white ink printing guide for
additional information.

Fotoba trimmer support added as a new mark style in the labels and marks tab.

Mimaki SDK updated from 1.70 to 1.80.

Mimaki error 10/20 has been resolved on some systems by disabling the new preference
"Compress RIP result". This will make larger temporary files, but be able to output without error.
No longer get "Open Port Failed" when sending to a TCP/IP device where one of the digits is 0.
Desktop printer driver can now print labels and registration marks.

Summa: option to trim media after job now sends proper command to the cutter.

Mimaki JV3 / JV4 no longer gives an error message when sending a job while the printer is in
local mode.

Mimaki JV3 / JV4 now list all Firewire ports availble and can print to multiple at the same time as
long as each is on its own port.

Roland VersaCAMM contour cut alignment mark added to Job Properties.

Mutoh PJ-1304NX has been renamed to PJ-1304NX (Albatros).

Mutoh printer driver no longer gives error message when opening job properties for jobs received
from the Mac.

Creation-Kingcut no longer gives error for A-24, A-30, A-36 and A-48 cutters



ColorSpan BCI toolkit now installs compatible version to allow output, and many models
converted to use Ferret interface.

Added ICC profiles for ColorSpan drivers.

Wild cutter now send correct command to change tools.

Summa OPOS contour cut alignment now has improved accuracy.

Hewlett Packard DesignJet 4000 now sets correct options when sending from desktop
applications

Seiko 64s no longer gives error, "Printer status is abnormal!" and will stop printing.
“Error loading string“ now longer appears when using Encad 750 driver.

Liyu drivers now support Folder port.

Roland GX-24 no longer gives error message when opening default job properties.

New Drivers

Asbru: ASBRU_V545C, ASBRU_V645, ASBRU_ V745, COMPACT 30, COMPACT 54,
ASBRU_V1045

Canon: imagePROGRAF W6400, imagePROGRAF W8400, imagePROGRAF W8400D
ColorSpan: DisplayMaker 72S, DisplayMaker 72si, DisplayMaker 72sru, DisplayMaker 72uvx,
DisplayMaker 98si, DisplayMaker 98uvx

Creation-HK renamed to Creation-Kingcut and some models renamed and added.

DGI: DR-1904T 4C, DR-1904T 6C, VT II-62P, VT 1I-92P, XP-2506, DR-1904, XP-2506D

Dilli Precision: NeoDeluxe UVD-2506, NeoDeluxe UVD-3206, NeoPlus UVP-1606, NeoPlus
UVP-2506

Eastech: Eco-8700, Octra UV-6440E, Octra UV-8720E, Octra UV-8740E, Scutum UV-6440S,
Scutum UV-8720S, Scutum UV-8720S-4S, Scutum UV-8740S

Emblem: EC120, EC60

Epson: PX-6200S, PX-6500, PX-7500, PX-7500S, PX-9500, PX-9500S, Stylus Pro 4400, Stylus
Pro 4800, Stylus Pro 7400, Stylus Pro 7800, Stylus Pro 9400, Stylus Pro 9800

Epson ColorPage EPLC8000 driver removed

Fei Yeung Union: FY-3206S (3.2m/6¢color), FY-3204S (3.2m/4color), FY-2506S (2.5m/6color),
FY-2504S (2.5m/4color)

Foison: FY1504C, FY1808C, FY6150C, FY6250X

GCC: SignPal Pumalll P-132S, SignPal Pumalll P-60S

GongZheng: GongZheng GZY, GongZheng XL

Graphtec: CE3000MkII-120, CE3000MkII-60, FC7000-100, FC7000-130, FC7000-160,
FC7000-75, SignJet Pro JS300, Doujet 64, JH800-16S

HengXing: HX-1200, HX-1360, HX-720, HX-800, HX-960

Hewlett-Packard: Designdet 9000s (requires optional password)

Infiniti: Renamed all models to begin with "YF-". Added YF-1232I1IS, YF-18EC, YF-8180lll+,
YF-8250l111+, YF-UV1612S. Removed: 1218C-6, 1225C-6, 1504C, 3208B, 3212C, 3212C+,
3308B, 3308C, 3312C, 3360A, 6150C, 6180Il, 625011, 6320LQ, 8180C, 8180ll, 825011, UV1218
Inwear: Inwear 4C, Inwear 6C

JiaChen: JC-1100ds, JC-1100H, JC-1350ds, JC-1350H, JC-720ds, JC-720H, JC-850ds,
JC-850H

JHF: renamed to JinHengFeng.

JinHengFeng: VISTA 04B, VISTA 04B+, VISTA 04C, VISTA 04C+, VISTA 04C++, VISTA 04D,
VISTA 04D+, VISTA 04D++, VISTA 06A+S, VISTA 06AS, VISTA 06B+S, VISTA 06BS, VISTA
06C++S, VISTA 06C+S, VISTA 06CS, VISTA 06D++S, VISTA 06D+S, VISTA 06DS, VISTA 08A,
VISTA 08A+, VISTA 08B, VISTA 08B+, VISTA 08C, VISTA 08C+, VISTA 08C++, VISTA 08D,
VISTA 08D+, VISTA 08D++, VISTA 12A, VISTA 12A+, VISTA 16A, VISTA 16A+

King Rabbit: Rabbit HX-1200, Rabbit HX-1360, Rabbit HX-720, Rabbit HX-800, Rabbit HX-960
Kornit: Kornit 930, Kornit 931

Liyu: Liyu printer drivers are now included in non OEM products.

Mimaki: CF-0907-2, CF-0912-2, CF-1215-2, CF-1218-2, JV3-130SPIl, JV3-130SL

MydJet: Diecai-Jet3308, Diecai-Jet3312, Diecai-Jet3312 6C, Diecai-Jet3316, E-Jet3308,



E-Jet3312, E-Jet3312 6C, E-Jet3316, MyJet1804-K512, MyJet1808-126-Hi, MyJet1808-128-Hi,
MyJet1808-K512, MyJet1812-126-Hi, MyJet1812-126-Hi, MyJet1812-126-Hi 6C,
MyJet1812-128-Hi 6C, MyJet1812-K512 6C, MyJet1816-126-Hi, MyJet1816-128-Hi,
MyJet1816-K512, MyJet2204-K512, MyJet2208-126-Hi, MyJet2208-128-Hi, MyJet2208-K512,
MyJet2212-126-Hi, MyJet2212-126-Hi 6C, MyJet2212-128-Hi, MyJet2212-128-Hi 6C,
MyJet2212-K512 6C, MyJet2216-126-Hi, MyJet2216-128-Hi, MyJet2216-K512, MyJet2504-K512,
MyJet2508-126-Hi, MyJet2508-128-Hi, MyJet2508-K512, MyJet2512-126-Hi, MyJet2512-126-Hi
6C, MyJet2512-128-Hi, MyJet2512-128-Hi 6C, MyJet2512-K512 6C, MyJet2516-126-Hi,
MyJet2516-128-Hi, MyJet2516-K512, MyJet3304-SP256, MyJet3304-SP256-Hi,
MyJet3306-SP256 6C, MyJet3308-126, MyJet3308-128, MyJet3312-126, MyJet3312-126 6C,
MyJet3312-128, MyJet3312-128 6C, MyJet3316-126, MyJet3316-128, Poli-Jet3308,
Poli-Jet3312, Poli-Jet3312 6C, Poli-Jet3316, MyJet3308 8C, MyJet3312 8C

Mutoh: MC-750S, TC-1000, TC-1300, TC-750, PJ-2646NX (Osprey 98), RJ-8100 50K, RJ-8100
64K, RJ-8100 87K, SpitFire 100, SpitFire 65, SpitFire 90

Neolt: NeoltJet UV 2050, NeoltJet UV 2500, NeoltJet UV 3200

Nur: Fresco 18, Fresco 32, Ultima 32, Ultima 5, Tempo, Expedio

Orasign: FY1218C-6, FY1225C-6, FY1504C, FY3212C, FY3212C+, FY3308C, FY3312C,
FY3360A, FY3360EC, FY6150, FY6250LQ, FY6320LQ, FY8180C, FY8250B, FY8250C, FY8320,
UVv1612S, W-Jet 160

Roland: SOLJET PRO Il V SJ-1045 EX, GX-24, AdvancedJET AJ-1000

RundJiang: LJII1800-UV6S

Scitex: Scitex Grandjet, Scitex Grandjet V3, Scitex Grandjet V5

Seaband: SB-M2

SeikiTech: SK-1100ds, SK-1100H, SK-1350ds, SK-1350H, SK-720ds, SK-720H, SK-850ds,
SK-850H

Summa: S140 D, S140 T

Technoplot: SolventJet-Basic SP300, SolventJet-Basic SP540, SolventJet-Combi 545,
SolventJet-Combi 645, SolventJet-Combi 745, SolventJet-Pro 545, SolventJet-Pro 645,
SolventJet-Pro 745, Creation CT1200, Creation CT630, Millennium T1600 Pro, Millennium T610
Pro, Millennium T750 Pro

Teckwin: TeckPro H5000, TeckSmart UV1600

Vivagi: Vivagi XL

Wit-Color Digital: Wit600H12 Fly, Wit600H16 Fly, Wit600H8 Fly, Wit6720H12 Fly, Wit720H12 Fly,
Wit720H16 Fly, Wit720H8 Fly, Ultra 720, Ultra Max H4, Ultra Max H6, Ultra Max XJ500-3300,
Ultra Silver H6, Ultra Tiff-3300, Ultra XJ128-3300, Wit180H12 Fly, Wit180H16 Fly, Wit180HS8 Fly,
Wit360H12 Fly, Wit360H16 Fly, Wit360H8 Fly, Wit6360H12 Fly, WitMax180H2 Fly, WitMax180H4
Fly, WitMax360H2 Fly, WitMax360H4 Fly, WitMax6180H6 Fly, WitMax6360H6 Fly

Xerox: 8142, 8160

Yaselan: YSL-Super, YSL-D2300S, YSL-D2300T, YSL-D2600H

Hewlett-Packard: DesignJet 9000s

The HP Designdet 9000s requires an optional password to unlock.

After unlocking the driver, insert the Output Profiles CD1 to install color profiles. This must be
done after unlocking the driver, or no profiles will show up.

The Output Profiles CD contains only profiles for HP branded media. Profiles for other media (3M,
Avery, MetaMark) can be downloaded at the http://www.SAintl.biz web site.

When the 9000s is attached to the PC, it may prompt you with "Found New Hardware". The
necessary Windows USB driver files for this printer can be found on the installation CD in the
UtiNHP DesignJet 9000s USB driver folder

Installer

Updated to latest version of InstallShield 10.5 to improve installer performance.
Dropped support for Windows 98, ME, and NT. Software requirements are now Windows 2000 or

Installer now has an option to install only the hardware key driver. In addition, if the driver is



already installed, this option will automatically be set to unchecked (reducing the long wait and
the end of installation). The version number of the key driver will be shown in the install dialog.

. Clear preferences dialog no longer appears during install, instead there is a checkbox during
install.

. Reboot is no longer suggested after installation, unless you install over an existing folder.

o ICC CD (CD2) now auto launches when inserted, so there is no longer a need to browse for
installer.

o Uninstaller no longer gives an error message that a file cannot be deleted.

. Contour cut guide updated.

. Version number now shows in add/remove programs.

. Help file now includes a full color cover and back.

. Help menu now has command to show color profiler help file along with a link to Scanvec

Amiable web site.

. CD installer no longer shows progress bar as it starts up, plus no longer installs CHM support
files during finishing install.

. Help menu for production now includes option to register, go to web site, and view color profiler
help file.

. Adobe input ICC profiles updated.

. Pantone (R) sample EPS files added.

. Installer now supports direct installation of PTF output profiles.

. Installer is able to be customized by dealers to add and remove files.

. Installer no longer prompts to clear preferences if you are installing on a clean system.

. New Vinyl Sign samples install.

. Installer can now be configured to remove files from installation for dealer customization.

Presets

) Preset selection added to Default Job Properties.

. Export preset can now be saved as "read-only". Previously, this option was ignored on export.

) Presets now apply cut settings when selected from RIP and Print dialog.

o Cutter Driver options and Use Embedded ICC now get applied from preset in RIP and Print
dialog.

o Preset list is now alphabetically with all read only presets shown first in brackets.

o Presets now default to save only Color Management, Printer Options, Color Adjustment

o Media and preset list now show more items without scrolling.

o Fixed a preset import issue introduced in Service Pack 1 where Roland VersaCAMM and some

other presets set the wrong driver options. Any presets saved with SP1 will reset driver options.
o Presets changed to a combo box in RIP and Print dialog.



