My driver has disappeared

elfin signs

New Member
Help, Had vinyl plotter & flexisign Pro 7.6V2 for 6months,today pc states Windows does not recognise device,When i send job to plot in production manager 'cannot open port' unplugged usb & re-inserted Windows does not recocgnise.I went to devices & port states unknown device,i have removed & re-installed all but with no difference,If anyone can help that would be great CHEERS in advance
 

joeshaul

New Member
Did you do any kind of service on the plotter and possibly leave a ribbon cable unplugged/plugged in wrong on the inside?

Kind of sounding like the USB chip isn't communicating properly, hence the Unknown Device.

Some other common troubleshooting ideas before you rip the machine apart:
If using a USB hub, bypass the hub and plug directly into the computer and see if that makes a difference.
Try a different USB port on the computer.
Try a different cable.
Check the vendor and hardware ID in device manager (right click My Computer, go to Properties, find the Unknown Device, click properties, then Details) and make sure it matches the plotter.
 

elfin signs

New Member
Unknown Device, click properties, then Details(It says no driver installed,I have re-installed & tried again no joy!,
Using Windows XP,tried my epson printer is same port(port is on pc)& it printed fine using same usb cable to printer.tried it in different usb port same 'Windows does not recognise device,click here to resolve etc..
Cutter Model??bought on ebay 8months ago Company is no longer ebay user!!!!!!
When i installed software it told me to use roland pnc1000 as set up????
It does have a com port or will i still get the same issue Thanks for speedy responce both
 

joeshaul

New Member
You might run into issues with the serial port, but it's definitely worth a shot.

Serial and parallel device programming is much more brutal and low level than USB, so you won't really get a "device detected" or anything like that when you plug it in. Instead, you will basically have to install the driver, tell it which port it's on, and just try cutting. If you're unsure of the port, you'll have to switch the driver to the next serial/printer/com port and try again.
 

CS-SignSupply

New Member
attach a picture of the cutter here for us to see... My guess, it is a SeikiTech or similar China model.

If possible, try connecting to different computer and install the driver there. Just to see if you can get the PC to recognize the cutter... Can not eliminate the possibility of a dead mainboard.
 

elfin signs

New Member
tried it in different ports,still same issue Windows does not recognise,had disk with driver on tried to uninstall but prompted me to 1st install so i did then prompted me to plug in device,same result,when i go into device manager it states unknown on the usb,went to properties,details, states no driver when i even try roll back AVIN A MARE, Cannot post photo as plotter is in my works unit,HEEEELLLLLLPPPPPP
 
Top