• I want to thank all the members that have upgraded your accounts. I truly appreciate your support of the site monetarily. Supporting the site keeps this site up and running as a lot of work daily goes on behind the scenes. Click to Support Signs101 ...

getting ready to lose it. CX-24 Write port error.


New Member
I have a roland CX-24 connected to my local machine VIA LPT1.

In flexi 7, which has been working perfect for a year, i now continuoisly get "write port errors" it cuts, pauses, cuts for a second, pauses, then gives that error (possibly a timeout error?)

this is what i ahve tried to rectify the situaltion:

1) cleared prefierances and rebooted.
2) switched to serial port (which dosent work at all)
3) removed 256 ram (incase it was defective, I added it before this problem started)
4) booted up into the bois and changed the LPT mode from ECP+ECC to normal.
5) called up the suplier i got it off (have yet to hear back from him)
6) removed all USB utilities from my machine. (switched my dongle from usb 2.0 to 1.1)
7)freed up a gig of space.
8)reinstalled CAMM-1 Drivers.
9)took a day off
10)searched google for "write port error" which leads me to numerous flexisign related forums. (with no answers other then clear preferances)

I'm really close to the edge right now ;) I have some small decals that need to be cut within the next few hours. I'm contimplating taking my vinyl to a shop a few blocks down and getting them cut there.


New Member
MOD-Z-CHRIS....HOLY TABER-NAK....hehehehehe try the test cut...if is works right then you have problems with your computer...maybe your runnin XP with SP2? if so...there is your problem.


New Member
test cut via OS or test cut on the plotter itself? I did a test cut on the plotter (the circle with the square inside) and it works flawlwessly, no slowdowns, so it's not somethign on the plotter.

yes I am running XP SP2, but this problem poped up yesterday. in the morning I did a cut, and by the afternoon it was acting up. no changes in hardware, flexi wasnt even closed. I cut. walked away and 2 hours later it wouldent cut.

as far as SP2, it seems liek it only has problems with an outdated HASP instructionset, which is "fixed" in an update I just got, but it dosent seem to fix my problem (mabey its for a different problem)

edit: sorry, i dont mean wouldent cut, it CUTs, its just REALLY slow, it takes about 1 min to cut "1.00" with all the pauses. if I try cutting more then a 5k document, it times out. (more then 10 characters)

edit 2: I have been running SP2 for months now. it hasnt been an issue since yesterday.


New Member
HAHAHAH %systemroot%\$NtServicePackUninstall$\spuninst\ does not exist! there is no uninstallation for sp2 on my system!


New Member
I am running systems with XP SP2 utilizing USB and LPT port connnections/keys and have not encountered such problems. I have used a CX24, Versacamm, PC60, EP7600, EP2000 and a HP5650 - all at the same time spanned across 2 systems shared with each other as well. I would recomend the following;

Simple things first - change the cable and use bi-directional. May throw a LPT card in it and change your BIOS to show LPT2 (new port) to being default and plug your unit into it. These probably won't fix you, so I listed some other options to try.

(1) Go to the Control Panel / Printers. If the CX24 shows up, right click and delete it. Then, even if the CX24 did not show, click the drop down menu of FILE and select Server Properties. It don't matter if your on a network or not. It dont matter if its really a server or not - just do it......... :) Click on the drivers folder tab and find CX24 and delete it. Then reinstall the driver. If this dont work, go on to the next solution possibility.

(2) Right click My Computer and slect properties, click on hardware, then device manager, then ports, and select the LPT port and remove it. Reboot and reinstall the driver. If this fails to resolve, I would remove FlexiSign and reinstall it to a new directory - not the default directory. This will require having your reg and password handy and will replace simetimes unfixable DLL files.

Hope this helps. I will be out of town until Monday, but will be glad to try othr possible solutions if still needed then.


New Member
Bryan, thank you for the help. unfortunatly it didnt work (exept for your suggestion to add a lpt port which is probably what I'm going to do.)

BUT..... I managed to get these letters printed! and you will not guess how :p :p :p

I enabled my wireless connection.

I went to my neighbors apartment.

I conected my computer to his network.

I took my CX-24 over to his place, connected it to his computer and shared it across the network.

NOT the most efficiant way, but it worked, and I got the letters printed, albeit a few hours late.

I still need to get this fixed, I'll probably have to go the route of another LPT port. but at least now I dont have any pressing matters.

edit: oh no! I just saw the time. It was my only day off work and I've essentially worked a full day trying to get this to work :(


New Member
hello guys,

i have the same problem 2 weeks ago, tried every thing, even re-formatting the pc. Still. didn't work. I called up our local roland dealer, and said maybe a driver problem, out of disgust and desperation, i decided to open the cover on the machine, and found that the main board is full of dust. a got a 2 inch. brush and clean the main pcb board remove all the dust specially around the parallel port connection area ,then all after cleaning the machine. it just got fixed somehow. just like that.

do you think the dust have anything to do with the problem?


New Member
Another grief area with the CX24 can be the multi plug for the parralel cable being knocked or the cable stood on. I went through your day of hell before locating the problem which was fixed by unplugging and re-plugging the cable at the plotter end.
I have a standby cheap P2 laptop running win 98 SE to fall back on if I suspect software dramas in my main PC. Well worth investing in a 5 year old laptop, I use it for doing sketches over digital photos when quoting on site, running a CD burner and a pile of other uses.