Graphtec CE5000-60


New Member
I just bought a vista computer and it will not communicate with my cutter. My resources sold me a new program,(of course), and it still will not communicate with my cutter. They are telling me that it has to run through the 25 pin serial connection but that still doesn't work. Does anyone know how to overcome this. Desprate!


What is your cutting software? If you are trying to cut straight from Corel you will need the windows driver! Other wise the cutting software should have the driver in it and needs to be configured correctly!


New Member
Driver for Vista

Graphtec, does not have a driver for vista 64 bit, just 32 bit. The new driver will be out in July for the 64 bit app.


New Member
Graphtec, does not have a driver for vista 64 bit, just 32 bit. The new driver will be out in July for the 64 bit app.
+1 ... Just went through this on my GX-24! One out of my three computers worked. I was not happy when told the update may not be out for another six months from Roland. :frustrated:


New Member
Apparently neither manufacturer has the drivers for 64 bit to run cutters. I do however, have it on good authority that it WILL work if you own a copy of Flexi. I have guys who didn't want to spend $800-$900 on software because they are so fluent in Adobe & Corel that they purchased a copy of FlexiStarter from me and just bring in EPS files to work around the problem and cut all day long. Email me with any questions, would be more than happy to help!


New Member
I just got a new computer with Vista 64 and use it with my CE5000. The USB drivers are not available, but it works just fine with CorelDraw and the cutting master 2 plugin with the serial connection. Just make sure the cutter port settings match the serial port settings and the cutter is set to GP-GL, cutting master will not work with the HP-GL and you will get an error on the cutter.


New Member
I just hooked up my Vista 32 laptop to my CE5000 and it will not bring up the graphtec cutting plotter controller when I send a cut job from an application, just as I do from my xp computer. Owners manual says that it can be set to either open from the start menu (which will only allow you to do a test cut) or you can choose to have it open from the print menu (which will automatically open it when I send a cut job from an application). I can only open the cutting plotter controller from the start menu and it will not open otherwise like it does from my xp computer. I see no where to change this setting. If anyone has any experience or knowledge of any of this, please share. I am using the updated driver. Thanks!


Premium Subscriber
I'm running Windows 7 x64 using lllustrator CS3 and the plugin with my little Graphtec Craft Robo without issue. I did download the latest x64 drives from their website and all the latest software. As I understand it the Craft Robo uses the same software as it's big brothers.