• I want to thank all the members that have upgraded your accounts. I truly appreciate your support of the site monetarily. Supporting the site keeps this site up and running as a lot of work daily goes on behind the scenes. Click to Support Signs101 ...

Tech Support Needs Tech Support

Fred Weiss

Merchant Member
I have a customer that purchased my EPS clipart collections recently who runs SignLab, at least version 6 but not sure of exact version number. All of the EPS files are saved in Illustrator 3.0 format and are black and white.

The customer is having success using most of the files sent him but has called reporting a problem with two of them. The problem is:

The file imports the vectors but will not show a filled version of them. In one of the two cases the file will not cut when sent to the plotter, the other one will cut. I have checked the two files over from top to bottom in Flexi, Illustrator, CorelDraw and Omega and they perform normally in all these apps.

Does anyone have any ideas as to what to suggest to him? I don't have SignLab so I can't test it to see if I can duplicate the problem. Does anyone who runs SignLab have time to see if these files will import cleanly for them and report their findings back to me?


New Member
Fred.....the palm trees came in ready to cut in outline (black) only. the owl imported but came up blank......I tried to select a color just to see if anything came thru....but nothing was there, eventhough it showed something was 'selected'. I tried welding, breaking path, connecting path.... still nothing.


New Member
fred take those files into corel......then export to them to disk as a CMX. signlab will read a cmx easily. also take those same files into corel and expot them as a EPS ENCAPSULATED POST SCRIPT, then save that to a disk...
make sure when you have these files in corel you can ungroup them, make the line thickness hairline, take out any color and see how clean the lines are in corel then do the export. sometimes stuff goes to signlab as 2 images.....one exactly on top of the other...and signlab will cut it twice.


New Member

Hi All

I have a simular problem as Fred, but with PLT files. I've treid importing them into corel as mentioned but get nothing.

PLT File's I have originate from Compossor. But it's a real pain using them in Signlab 6.1

Also using a Camm1

Had problems with setting that up at first, had to edit the .INI file to get it to work right.

You would think for the price of this software the drivers and import function would work.

Also disapointed with the manuals that come with it, and the help on the cadlink website is as much use as a hole in the head. Theres conflicting information that you have to debug yourself.

Thats my rant!


Bob Gilliland

New Member

Not 100% clear on your issue, so please confirm or correct anything stated.

Gerber .plt is a proprietary format unto themselves and is not the same as HP .plt files. So any program that has an import/export plt filter may not properly interpret the data to the Gerber plt format as it is structed for the HP format. SignLab is one of very few programs that read Gerber plt files and does a fairly robust job with it (Corel is like most others, no support for Gerber plt). It currently doesn’t lend full support to Omega 2.x plt formats and does, on occasion, stumble on other Gerber plt files, but in the big picture, is rather strong. What is your current installed revision level? Current rev is 13 on the e6.1 package. I would encourage you to move up to this release if not currently there as the Gerber plt import filter has seen much improvement since the product was first released.

SignLab software is no different then other software in the market place, expensive or not. You have two options (speaking from a software manufacture standpoint) when it comes to import and export filters, make your own or outsource to a third party. The later is becoming much harder to find and with any outsourcing, you’re at the mercy of that source from a quality standpoint. Writing your own is not always cost effective and requires much effort and resources. Even then, unless you have been given the exact “playbook” so to say, it will be very difficult to properly interpret the data file 100% correctly. As programs support more and more bells and whistles, this becomes an ever increasing situation to deal with. Much more so when dealing with relatively small, lesser known or proprietary file formats. Not making excuses for CADlink, Gerber, or even Adobe, just mentioning some real world issues (and not limited to just “graphic” based file formats or software products).

Did you take the time to contact CADlink about the problems you had? They are in the software business and not the mind reading business. Unless they are informed of a problem, chances are it won’t get attention for possible correction sooner rather then later. Also is great help if you mention specific problems as opposed to general displeasures when attempting to troubleshoot such items. :smile: Please don’t interpret the above few sentences as a lecture, as it isn’t meant as such. :smile: It is however stated to encourage anyone reading this to contact CADlink (or other vendor) about issues being faced.

SignLab and documentation; yes, I hear you. I have expressed my displeasure with the manuals and Help file for some time now to various folks within the organization. Again, I would encourage you to contact them direct and state as such. Perhaps if more people expressed this “direct” and to the dealers that they purchased the product from, it may move up on the priority list. “You” may have a good product, but if “You” can’t communicate to the end user on how to use it, what are the chances the user will abandon the product before learning of the “greatness within”? SignLab is intuitive in some aspects and not such much in others. Additionally, when providing more features to thermal devices in particular, unless very familiar with the process already, it is very cumbersome to “learn” from the current documentation (hardcopy manuals or software based Help files) set.

Thanks for your post and hope to see more in the future.



New Member
Hi Bob

Thanks for replying and apologise for not getting back sooner. My initial post was not placed to provoke a response, but I will take any help offered, TX.

“Please don’t interpret the above few sentences as a lecture, as it isn’t meant as such.”
No offence taken, I have skin thicker than a rhino, but some times it does helps to have things put in lecture format just to hit home.

So here goes with the explanation if you can call it that.
Version of sign lab being used is E6.1 revision 13, this only holds up the case that I’m new to Signlab, I hope.

Original PLT files were created or digitised in Composor 6, some of the files have been taken into Omega and re-saved, but this does not seem to elevate the problems.

I’ve sent two files to your listed e-mail address (signature) because I’m not to sure how to attach them to the board, hope you don’t think I’m taking liberties.

One when imported to SignLab shows nothing, so I can’t do anything at all with it. But it does show in the preview window when importing.

The other comes up with for want of a better word, multiple layers. This file multiple cuts.

I have also had a file that I’ve since sorted out, that put multiple nodes on a curve creating a straight line.

Both files were taken into Omega and saved with no fill or stroke. But even with the fill and stroke left on, same problem, also on importing tried a verity of option thick line turned off etc.

What’s the most frustrating point for me is that you can apply a work around to one, but when it comes to the next something completely different is required.


Bob Gilliland

New Member

:thumb: Thanks for the follow up. Don't worry about the time thing, we all have "real" jobs to attend to.

All of what is below was with the same version of SL you currently have, e6.1 Rev 13.

The "ducati3.plt" file imports "empty" for me, so I'm going to go on the premise that is the one doing the same to you. Looking at the data file itself with a disk editor (not opening it inside Omega or Importing into SL), appears that the file was saved from Omega version It has no printing attributes what so ever, only an "unknown color 1" vinyl assigned (probably has a vinyl palette I don't have available). I would consider this a relative "simple" design for the import filter to handle, however, something is causing great issue. If I save the file down to a Graphix Advantage 6.2 file format (from withim Omega 2.02) and attempt to Import or Open that "new" file, there is no no problem and full integrity is present. This is telling of something, however, beyond my reach as to what that is. With your permission, I would like to forward this on to the developers at CADlink. Would also like to add that working with the original file sent (Omega or the "saved down" GA 6.2 version caused stability issue within the SL program.

The other files, PS2.plt, appears to also have been saved from Omega This file Imports and Opens fine. Again, no printing attributes present, only six layers of vinyl. The multiple layers you are experiencing inside SignLab are a result of the various vinyl colors used within the design. This is "normal" operation of the plt Import filter. If you haven't experimented much with layers, do a left click on one of the layers while holding down the ALT key. This will isolate the view to only show the objects in that layer with all other objects hidden from sight. Another left click/ALT operation will toggle back.

Each layer is assigned its own vinyl attribute. If you were to double left click on one of the layers without having anything selected, the Layers Property dialog will display and show what vinyl family and color is assigned (along with one or two other bits of information). The "easiest" way to consolidate all objects onto one layer is to single left click on the Layers Context Menu and select "Collapse All Layers". A word of caution though; all color information will be lost because the objects took their color attributes from the "layer" and not from an object perspective. If "I" were doing this (doesn't make it the right way is what I'm trying to say) I would isolate each layer, select all the objects in that layer and assign a vinyl color from a vinyl palette. After this is done for each object on each layer, then collapse all the layers so that each object retains the proper color attribute. I think you'll find this also will correct "double" or "redundant" cutting from happening. Since I didn't go through the entire exercise outlined above, you may also have to play with some stacking order issues in order to have the overall layout integrity remain. Not sure about that one. All in all, I would say that this particular file imported "correctly".

Now, if you agree with how it works....well, that is a different post!! :biggrin:

Again, I don't want to make an excuse for anyone but will say that CADlink has done a bang up job in supporting Gerber owners with existing data files. They are not 100% (as you know all to well!!) but go above and beyond what anyone else has done to date (that I am aware of). As much as I praise the efforts, I will say there could be continued improvement. Currently, Omega 2.0 format is not supported. I believe that to be changing in the near future, however, currently it is not. Additionally, I discourage people from completely abandoning Gerber software if they have Gerber data files. The filter is good, but not so good that I would put complete faith in it to open my livelihood data files.

With your permission, I would like to forward both files to CADlink but have particular interest in the Dacati one. I can forward the actual cdl files created when playing around if interested, just say the word. :wink: