No ink coming through after changing heads


New Member
I’ve been having some issues with the heads on my sp300v, tried cleaning them but m/y head had nothing coming through and the blue was 95% clear and the black was about 40% on a test print.

Decided to just buy 2 new heads with new dampers and cap tops (I could’ve cried after the deceiving checkout process) but they arrived today, changed them all over, primed the dampers, changed the cap tops but there was nothing coming out.

Took the pipe off the Y piece to put a syringe on but there’s no resistance at all when pulling it, tried the old tops just to see what they did ‘cause I did it on them not long ago (ink came through both lines) and got the same thing of no ink and no resistance.

The fuse did blow the other day but that’s sorted now (before these went in) and I have just checked them again with the meter and they’re fine. I’m not sure what else to try or what it is ‘cause I can’t see it been the heads as they were brand new out the packet about 2 hours ago


DIY Printer Fixing Guide
When you change the dampers the ink will recede back to the cartridge. Did you do an ink fill or some hard cleanings after installing? Take the fuses out of the board to test them. Sometimes you will get a bad reading when they are installed for whatever reason. The fact that you aren't getting any resistance when pulling below the cap means the caps aren't sealing with the heads properly. It could also be that the ink is all the way back in the cartridges and you aren't feeling the resistance because the ink isn't close enough yet. The closer it gets, the more pull back you feel. Check you dampers and ink line and make sure there is ink in them!
Make sure to pull through the dampers to fill the ink lines, NOT through the caps as you can possibly damage the heads. Once the dampers have ink in them, as Jordan suggested, do a power clean. If you are not getting ink at that time, try pulling through the caps, BUT very gently. If you are getting no resistance, then you will need to "initialize the limit". Power down the printer in the front. Press and hold the left, right and up arrow keys while turning on the front power. Follow the prompts. If you are having issues while doing this, call me. Number is in my signature.

Jaya kishore

New Member
Hi ,Here i have some tips for you.
First of all you have to check the ink whether it is coming up to dampers or not?. From Dampers to head. Try to suck from Y junction connector. Chek the ink flow.
You already confirmed that Fuses ars working.
At this time check the cable connection from MAIN BOARD TO PRINT CARRAIGE BOARD, same way 21pin cables from PRINT CARRAIGE BIARD to Heads.
If you are facing same issue,I am ready to support can contact me on my whatsapp.7794942341