No ink ejection from dx7 heads

alexyoon.gaius

New Member
I just received a printer from WitColor that has 2 dx7 heads. Printer driver is all installed and ready to go, but the heads won't release any inks. I see that the inks are all loaded up to the nozzle, but the capping is not damped nor the heads. I removed the heads and tried to pump the inks by the syringe, and it worked by that way. I think there is a connection error or the printer is not detecting the heads, but I can't be sure. Did anyone have same problem?
 

Attachments

  • image.jpg
    image.jpg
    58.3 KB · Views: 239
  • image.jpg
    image.jpg
    55.3 KB · Views: 209
  • image.jpg
    image.jpg
    33.4 KB · Views: 190

Solventinkjet

DIY Printer Fixing Guide
Just so you know, those aren't DX7 heads. Those heads look like they come from an Epson desktop printer. I have seen them used in Chinese knock off printers before.

When you pushed ink through with the syringe, did it print anything? Even a couple nozzles? Once ink has gone through the head, you should be able to get at least something to print. If not, it could be an electrical issue. The fact that the cap tops are dry is really confusing. How did you fill the ink line and dampers in the first place? You must have done it manually with the syringe or something. To me you either have an electrical issue or the cap tops/pumps are malfunctioning.
 

alexyoon.gaius

New Member
Just so you know, those aren't DX7 heads. Those heads look like they come from an Epson desktop printer. I have seen them used in Chinese knock off printers before.

When you pushed ink through with the syringe, did it print anything? Even a couple nozzles? Once ink has gone through the head, you should be able to get at least something to print. If not, it could be an electrical issue. The fact that the cap tops are dry is really confusing. How did you fill the ink line and dampers in the first place? You must have done it manually with the syringe or something. To me you either have an electrical issue or the cap tops/pumps are malfunctioning.

I can't be sure if they are not DX7 heads.. but I will double check.

I manually pulled out the ink by syringe, and could see that the ink was not dried. I contacted with the Chinese manufacturer yesterday for a few hours and I found out that the only problem I had was that capping and head was not 100% accurately aligned. Only a little bit of head position adjustment was needed to suck out the ink from the damper!
Thank you for your idea.
 

rjssigns

Active Member
You'll have to report back on how well the printer works for you. IIRC there was only one other person on this site that had a WIT Color. And that was a few years ago. They seem to have disappeared.
 

alexyoon.gaius

New Member
You'll have to report back on how well the printer works for you. IIRC there was only one other person on this site that had a WIT Color. And that was a few years ago. They seem to have disappeared.


The model we bought is the Ultra9200-3302S series and we purchased through a third party company in Shanghai.
Their customer service isn't that impressive.
They will normally respond you back within a few hours, but sometimes they just don't get back to you at all.
I tried to contact every single agents in that company when I needed some help and a few of them will respond you back but others won't.
I think you should consider buying the printer directly from WitColor than third party companies since you can't get direct tech support from WitColor if you don't.
You would have to pay extra service charge to WitColor if you need any help from them after you bought the printer from anywhere else.


About the printer, I'm liking it a lot. After I solved this issue with the ink, I've done some test printings and I'm impressed with the speed and quality..
maybe I didn't have too much expectation since it's from China after all..
but the printer is built in good quality for sure. I received Maintop with the printer and it's pretty straight forward to use.


But to be honest, When I first received the printer and software, I was pretty disappointed because none of software CD they sent me won't work.
Printer software CD was sent with nothing in it. No files at all.
They sent me a zip file that has the installation file in it, but they didn't give me the correct password so I had to wait for another couple of days to receive it, and when I did, it won't install on any of my computer!
I downgraded my computers to XP SP3, Windows 7 32bit and tried everything I could but nothing worked out.
I somehow managed to have it installed on one of my oldest computers but I have no idea how that went through...
But I bet you won't have to suffer these things if you buy directly from WitColor company.
 

rjssigns

Active Member
Thank you for the thorough report. Sounds like it's a nice rig after the "teething" issues. Keep us posted if anything new develops.
 

capista

New Member
I can't be sure if they are not DX7 heads.. but I will double check.

I manually pulled out the ink by syringe, and could see that the ink was not dried. I contacted with the Chinese manufacturer yesterday for a few hours and I found out that the only problem I had was that capping and head was not 100% accurately aligned. Only a little bit of head position adjustment was needed to suck out the ink from the damper!
Thank you for your idea.

hello i have the same problem the head is not perfectly alligned with the cap i have bannerjet with dx7 head any help
 
Top