Major CorelDRAW X3 Problem

Bobby H

Very Active Member
I've waited and waited for Corel's tech support people to get back to me on this problem and haven't had any luck with the CorelX3 Usenet newsgroup either. So I'll try here to see if anyone has had this problem:

Currently, CorelDRAW X3 is "dead" on my computer. I cannot get the application to reinstall -after doing a manual clean uninstall procedure described at Corel's website (which involved using a Microsoft uninstaller utility). The attached JPEG screen grab is how far the installer gets before hosing itself.

I have gone through this computer and removed every possible mention of Corel. Virus scans, spyware scans and runs with Registry Mechanic have been made to get rid of any evidence of Corel's existence on this PC. Nevertheless, I still get this "Error 1714" box claiming the older version of CorelDRAW X3 cannot be removed.

Aside from totally formatting my C: drive and doing a fully clean install of Windows and all my applications I don't know what else to do in order to fix this problem. I'd prefer not to have to format C:. Adobe Production Studio Premium took over an hour on its own to install.

I'm hoping there's some kind of simple fix to cure this problem.

This issue began over a different and major CorelDRAW X3 glitch that got me on the uninstall/reinstall path.

I loaded the Formata BE type 1 font family from my collection of Adobe Illustrator 4.0 fonts into Adobe Type Manager 4.1 Lite. Even though I've used this high quality type family many times before CorelDRAW X3 decided it was now going to lock up whenever I selected the text tool. I tried doing the normal uninstall thing, using Corel's own uninstaller. That didn't work. I tried removing all my type 1 fonts, removing ATM 4.1 and then reinstalling CDR X3. It still didn't work. X3 would just lock up all over the place. That's when I had to start looking at other alternatives to really get a clean install.

Aside from CorelX3 refusing to install, everything else on my computer works perfectly. No software or hardware issues elsewhere. (FYI, my PC is a Dell Dimension 9100 with Pentium D 840 CPU, GeForce 6800 video card, 2GB of RAM and running WinXP Pro SP2)

Any other CorelDRAW X3 users experience this kind of thing?

This issue has inspired me to convert more of my sketch templates, spec sheets and other Corel-based items over to IllustratorCS2.


  • CorelDRAWX3Error1714Box.jpg
    80.3 KB · Views: 100


Major Contributor
Have your tired restoring Windows to an earlier happier time that predates your Corel troubles? It often works in these situations. Then it often doesn't do a damn thing either. But it's worth a try.

Bobby H

Very Active Member
Yep. Did that already, although it was a good suggestion.

System Restore didn't do squat. It only told me it could not restore to the previous point I chose. Oh well.

I've been web-searching more and more into this "Error 1714" thing and it seems to point more and more to an issue with WindowsXP and its Windows Installer service rather than an issue with the actual application being installed.

Possible solutions vary. Some suggest downloading and reinstalling the Windows Installer Service module of Windows. Others say its an offending "MSI" file being referenced by the installer service and if that file is found and deleted the problem will be solved. Trouble is there's lots of those files hidden in the Windows folder. Then others suggest using the Windows Installer Clean Up utility. That's the stinking thing that started giving me the 1714 error in the first place. Geez.


Major Contributor
RESTORE IS NOT FOR FIXING stuff like that,,,,

The problem may not bi in corel but in the windows installer,, there was a bug in that.. dotn know where u are in the updates..
have you tried this one..;en-us;290301

and this

Yer next best solution is to clean the registery completly,,
use regedit and remove all instances of corel from there,, Mechanic does not get all the registry entries.. manually works best..

then remove all the corel folders,,
then try your reinstall.
Make sure you clear all the temp folders as well. Why? because installers use temp folders to unpack,, and that is where the problem may lie as well.
If then it doesnt work the installer has is corrupt..

Or in a few cases, the script handler buggers..,,
1. Start the Control Panel Internet Options applet.
2. Select the Advanced tab.
3. Under the Browsing section, select the "Disable script debugging" check box and clear the "Display a notification about every script error" check box.
4. Click OK.
Last edited:

Pro Signs & Graphix

Very Active Member
$100 says that you have IE Explorer 7 installed on your machine.

If you do, get RID of it! The beta, although seemingly nice CONFLICTS with a good number of softwares - which BTW will be an issue once Vista is released. The software manufacturers are going to have new versions or patches everywhere.

Bobby H

Very Active Member
Pro Signs, you lose $100. I don't use IE at all. I'm strictly a Firefox user. The only version of IE on my machine is what came with WinXP Pro SP2 (some variant of IE 6).

I've gone through the Windows registry manually and deleted every mention I could find relating to Corel, as well as running Registry Mechanic. All temp files have been deleted, all Corel folders deleted, etc. The 1714 Error still persists. This stinking problem is as bad, if not even worse, than some computer viruses.

Again, I tried Microsoft's "solutions." Their "Windows Installer Cleanup Utility" is what caused the Error 1714 messages to begin appearing in the first place. Before that Corel simply wouldn't uninstall/reinstall clean enough to correct the problem of the text tool crashing the program whenever I selected it.

I've looked through this issue all this morning so far. Other forums and websites seem to point more and more at formatting C: as being the only way to really cure the problem.

Error 1714 is exactly the kind of thing Apple should be using in its typically broadly inaccurate Microsoft bashing ads. Error 1714 is a real problem and apparently pretty common.

Pro Signs & Graphix

Very Active Member

Reformatting may end being your only solution. What plug-ins do you have with FireFox? The reason I am asking is that there IS a bunch of new "code" that is causing problems. So far, we have not seen any FF users (just IE users) but in every case it leads us to the browser - sooner or later Mozilla will be catching up too.

The other thing we have noticed is that there is a lot of anti-virus/anti-spyware software causing issues.


Major Contributor
Bobby H. I know this is a little late but if I were you I would look into a imaging program. I have Acronis and swear by it. Saves a lot of time when problems like this creep up.

Bobby H

Very Active Member
I tried downloading the latest version of Windows Installer available on Microsoft's website (version 3.0). The package refused to install, stating the one on my machine was a newer build.


I found a version 3.1 of the Windows Installer. It sucessfully installed. But I'm still getting the Error 1714 problems with CorelDRAW X3.

Unfortunately it seems the only way this Error 1714 thing is going to be smashed is by formatting C:
Last edited:


Very Active Member
the commercial says Macs don't get viruses or have problems ever is this not false advertising? How they getting by with it ?


Have you tried searching your registry and deleting all references to Corel? This can be a dangerous thing if you don't know what you're doing, but if you're considering reinstalling Windows anyway...

You'll need to uninstall any other Corel products first.


Major Contributor
its not the registry,, its not corel,, its the MSI in the installer,,
Its big problem in a load of softwares.

Lots of software has a patch for fix it,, It seems corel does not,, yet...


Major Contributor
Bob and Techman have either one of you ever looked at Acronis? Believe me it can get you out of a lot of issues like this and you will not lose any of your files! Look into it, it's a great program that doesn't cost a lot.


Major Contributor
ive tested all of acronis stuff at one time,, yes its good,, going back to a previous install may work this above casse,, if you can go back far enuf..
however, its mostly faster to fix the installer ..
I am of no help here in this case because I am not at his machine..And have no idea where it stands with SP's and updates....

I would likely do a limited reinstall of cerain parts of the OS if it was my mahcine.. Or do a CAB extraction.. Format C: would not be my choice,,

Pro Signs & Graphix

Very Active Member
Tech - Is there a way you can explain on how to fix the installer?

Up until now, all of the conflicts we have been finding (former colleagues/associates with repair shops) have been related to BS beta software. Usually the already installed software quits working. Clean removals of the betas have helped tremendously.

What is happening with the installer that is causing installs to freeze?

I get these calls because the softwares that give them issues are proprietary for repair and invoicing and the average person does not know how to even run the software, let alone how they should.


- Have you tried deleting the Corel installation files from the Applications Data folder which is created under Documents and Settings > Administrator (or other username under which the old version was installed)?

- To see the Applications Data folder you will first have to enable Show hidden files and folders radio button (which is off by default) in Windows Explorer > Tools > Folder Options > View.

- Delete the Corel folder under Applications Data and you should be able to re-install the application if you have deleted all entries from the registry.


Major Contributor
have you looked at this area in the registry?
Look thru the list to see if corel is still there..
Dont go there if you are not familiar with registry work..

The installer cleaner is known to work. The file may not be lited by name. If it is corrupt it may be listed as some strange character such as an arrrow or a tilde ~ or some other unknown variant. Some have taken the chance and deleted one by one any of these strange instances and reboot after each deletion.. In fact I saw one in a machine for Backup my PC software. I deleted it and all was well afterwords.

IT is not Corel. It is the windows installer IMHO.

By default, the FindRelatedProducts action is inserted into both the UI and Execute Sequence of a project. During a major upgrade, if both instances of this action are called, it causes the MSI engine to try to remove the old product twice. The MSI engine fails when trying to remove the product the second time when using a InstallScript MSI project .

It seems to be a corruption in the installer database. No,I do not have the means to fix this..

The fix seems to be this: You have to be an Install shield expert..
The following steps set up a condition on the FindRelatedProducts action so that only one instance is called:

1. Navigate to the Sequences view.

2. Expand the Installation folder.

3. Expand the Execute sequence.

4. Click the FindRelatedProducts action.

5. Find the Condition field on the right side of the screen. Add the condition NOT ISSETUPDRIVEN to this field if it is not already present.

All this is found in the sequence table..

Here is the place that explains more. As you can see you need to be a technician to follow all this...

The reason so many vendors have a patch for this problem is because they can..
Here is the info they use.

I remember working on this problem before several times with other products. One workaround was to install the software into a different folder.