New to printing

Jrs187

New Member
Hello and thanks for allowing me here. I just purchased some used equipment. So far I have just been cutting vinyls with my sc2 uscutter for about a year. I just purchased a mutoh vj1204a printer. It had some issues that I didn't think were going to be that big of deal but I think I was wrong. It had some codes but got them sorted out now I have ink pulled through the dampers but it won't print. Is there somewhere else I need to look? Sorry if I'm not posting in the correct area completely new here. Thanks for your time
 

Gino

Premium Subscriber
Can the people who sold it to you help you out ?? Even if it's not a dealer, they should know what's going on. Otherwise, I would say you were..... HAD.
 

Jrs187

New Member
Hes looking at it also. We're just looking for more options. I've been friends with him for along time. We were looking online and it says something about maybe f2 fuse but we can't seem to find it.
 

signage

New Member
Do you even know how to test a fuse/fuse able link? Those fuses aren't glass tube type fuses.
 

Jrs187

New Member
Yes I know how to test fuses. I just can't seem to find where f2 is located on any of the boards. I tried calling the number mutoh gave me for a repair tech but either they got a new number or went out of business.
 

signage

New Member
I don't have a picture of the location of the fuse but here is what it looks like and if my memory is correct it has marked by the Fx.

1641511848920.png
 

Johnny Best

Active Member
Ask on here if anyone has the repair catalog for that printer. I have a Valuejet 1204 also. Still works great, after putting new print head, dampers and maintenance station in it.
 

Molydoly

New Member
Hi,
Hoping for your good health.

ask them from where you have purchased, request him to guide you. Clean the ink dumpers and pipelines which supply ink. May be some garbage is there. Or simply contact with with your seller.

Thank you.
 

Jrs187

New Member
Ended up purchasing new printhead should be here today. But like everyone says if they sit they get expensive.
 

Jrs187

New Member
It was the printhead that ended up being clogged and the cables being messed up. It's up and going. Played with it for awhile today. Thanks everyone
 
Top